Symptoms
When checking cPanel's Email Deliverability module, the records are reported as missing inconsistently show valid/invalid, or display timeout errors.
This issue can also be related to issues with determining whether a domain has local authority over DNS records, as well as AutoSSL checks, as it pertains to the libunbound resolver.
This issue has been seen to be related to IPv6 networking issues.
Cause
The WHMAPI1 function set_up_dns_resolver_workarounds was created to identify and workaround these networking issues. We've found that the function does not sufficiently detect IPv6 networking issues in certain states.
For reference, the case number is CPANEL-43976. Follow this article to receive an email notification when a solution is published in the product.
Resolution
There are three options for resolving this issue:
- Contact a network administrator to fix the server's IPv6 configuration. You can get started here:
How to diagnose IPv6 issues - Disable IPv6 with the instructions here:
How to disable IPv6 -
In SSH or the Terminal in WHM as 'root', run the following command to create the following touch file manually:
# touch /var/cpanel/dns_flags/has_broken_ipv6
Note: The touch file is only temporary and will be removed during nightly maintenance. Any issues with IPv6 configuration should still be addressed by a qualified systems or network administrator.
After applying any of these options, restart the cpsrvd service to load the change by running the following in SSH or the Terminal in WHM as 'root':
# /scripts/restartsrv_cpsrvd
If the issue persists after restarting the cpsrvd service, run the following in SSH or the Terminal in WHM as root to synchronize the installed cPanel version from our update servers:
# /scripts/upcp --sync
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