Skip to main content
cPanel Technical Support has been heavily impacted by hurricane Beryl and our ability to respond to tickets has been hindered as a result. We appreciate your understanding and patience as we address these delays.

[CPANEL-33877] Use transfert tool twice on a account with live option enable cause apache loop

Comments

33 comments

  • andrew.n
    So you used the transfer tools twice to migrate an account from one server to another server which probably overwrote the account but I don't really understand the issue here. Can you elaborate?
    0
  • youp
    the first time you transfert an account, the transfert tool with live option put an extra configuration in httpd.conf on the remote server like this : ProxyPass " if I restart a transfert, this configuration is applied on the new server, and cause a loop on apache ... -> AH00286: server reached MaxRequestWorkers setting, consider raising the MaxRequestWorkers setting Regards
    0
  • andrew.n
    Thanks for the clarification. Do you have root access to the server? You should make a manual cPanel backup and restore that on the destination server probably with Restricted Restore option enabled.
    0
  • youp
    probably, but it's something to check for the next release
    0
  • andrew.n
    Certainly..maybe @cPanelLauren has some further input here.
    0
  • cPanelLauren
    There is already a case for this I found, CPANEL-33877 Live Transfer feature can lead to infinite proxy loop resulting in Apache DoS - Multi Server Variant - this issue is fixed in v92 and there is a request to push the fix to v90. I'll update here when that has been completed. Thanks!
    0
  • youp
    thanks ;)
    0
  • domaincolony
    I have the same issue after moving data centre but even more annoying now the licence has expired on the old server, can we get a grace period whilst this issue is unresolved please
    0
  • cPanelLauren
    You would need to contact customer service for any requests such as this at cs@cpanel.net
    0
  • youp
    I have the same issue after moving data centre but even more annoying now the licence has expired on the old server, can we get a grace period whilst this issue is unresolved please

    if you have the ssh access to your server, you can edit httpd.conf and delete the proxypass directive ...
    0
  • domaincolony
    Can we have an update and solution please...? File/Directory Restore is still creating ProxyPass entries in httpd.conf - yes I can manually comment these lines out but this is a nightmare on server transfers.
    0
  • VM Creativo
    Same here: [CODE=apacheconf]VirtualHost 1.2.3.4:8080 [1234:1234:0000:0000:1234:1234:1234:1234]:8080> ServerName client_domain.com ServerAlias ipv6.client_domain.com mail.client_domain.com www.client_domain.com ProxyPass "http://server.ourcompany.com/" ProxyPreserveHost on DocumentRoot /home/client_domain/public_html ServerAdmin webmaster@client_domain.com UseCanonicalName Off
    Is there any way to disable the further creation of ProxyPass? I tried to comment on the httpd.conf file, but each time it is re-created it overwrites
    0
  • domaincolony
    As changes to httpd.conf are not persistant - on each rebuild, add/remove domain the file is rewritten and the ProxyPas statement added/reactivated - can we have a timeline for resolution in whm v90, please
    0
  • VM Creativo
    I have a temporary solution Make a backup of the vhost creation template: [CODE=bash]cp /var/cpanel/templates/apache2_4/vhost.default /var/cpanel/templates/apache2_4/vhost.default.bak
    Edit the vhost creation template: [CODE=bash]nano /var/cpanel/templates/apache2_4/vhost.default
    Remove these lines [CODE=perl][% IF vhost.proxy_backend -%] ProxyPass "http://[% vhost.proxy_backend %]/" ProxyPreserveHost on [% END -%]
    0
  • Bousaid Med
    facing the same probleme , can any one tell us the solution to resolve the problem of 502 and DOS of httpd and apatche.
    0
  • VM Creativo
    facing the same probleme , can any one tell us the solution to resolve the problem of 502 and DOS of httpd and apatche.

    See my solution above, it has been working for 10 days without problems
    0
  • Bousaid Med
    See my solution above, it has been working for 10 days without problems

    ------------------------------- Thanks for your reply , please correct me if i'm wrong : the solution is Removing these lines from vhost.default : [% IF vhost.proxy_backend -%] ProxyPass "http://[% vhost.proxy_backend %]/" ProxyPreserveHost on [% END -%] this solution would work , but i have to delette the current account with probleme and re copy it another time ??? or it would work without deleting the current account with probleme ?? thanks.
    0
  • drdoot
    Facing the same problem here. Frankly, I find it frustrating, as I do dry runs on transfers before doing the 'real' transfer. The proxy thing with automatic suspending the account AND modifying .htaccess is not a positive IMO. Turn it off by default
    0
  • tmcstom
    It's probably better to use the WHM API1 command referenced in the links below to remove the proxy variables instead of manually editing vhost template/configs: And for the mx routes (if present)
    0
  • colo
    0
  • cPanelLauren
    Hello, I just wanted to update that this is actually marked as resolved as of v90.0.08 and should no longer be causing an issue if you're on that version or higher. You can see this completion reflected in our changelogs here: 90 Change Log | cPanel & WHM Documentation
    0
  • colo
    We're on v90.0.10 with 2 servers down today. Somehow the migrationtool has set a proxy to it self. Build scripts should be able to detect a loop and remove the wrong settings. (Even if they have been introduced prior to v90.0.08)
    0
  • cPanelLauren
    @colo Could you open a ticket to have this looked at in that case, please? If you do can you update this thread with the ticket ID?
    0
  • colo
    We've fixed the issues on our servers following this procedure (I think :) ) SSH to webserver (or terminal via WHM webinterface) nano /var/cpanel/users/ remove line PROXY_BACKEND= run script: /usr/local/cpanel/scripts/updateuserdomains clear proxies via API: whmapi1 unset_all_service_proxy_backends username= run script: /scripts/rebuildhttpdconf service httpd restart What's missing for me is an API/script/interface to see what proxies are defined for an account (Or I don't know how to find them...) So it was a bit of a gamble when removing all proxy backends. The wrong proxy resulted in the following lines in /etc/apache2/conf/httpd.conf ProxyPass "http://" ProxyPreserveHost on Scripts like /scripts/rebuildhttpdconf should see that ProxyPass is setting a proxy to itself, resulting in a loop followed by an unresponsive httpd. I don't know if it's still benefitial to create a ticket....
    0
  • cPanelLauren
    Hi @colo I confirmed with one of our Senior Tech Admins that we can't replicate this behavior so if you're able to, a ticket would still very much be encouraged. We'd like to look at the configuration further and see what's happening. If there's an issue we definitely want to know about it.
    0
  • colo
    SSL errors on htps://tickets.cpanel.net and first time logon shows way to much legal stuff. I'll file a ticket if the issues comes back. :(
    0
  • cPanelLauren
    @colo What kind of SSL errors were you seeing? I wasn't able to replicate those when going to cPanel Customer Portal and if you run into the issue again, please do open a ticket so we can look into the issue further.
    0
  • albatroz
    Is there a way we can fix this manually? I need to revert back an account transfer but I am receiving this error message (proxy dest auth failed) even after using the command "whmapi1 unset_manual_mx_redirects domain=XXXX" as suggested by CPanel support (ticket 93850116)
    0
  • andrew.n
    @albatroz give this a try: cut -d":" -f1 /etc/trueuserowners | while read user;do whmapi1 unset_all_service_proxy_backends username=$user;done If only one account was transferred then: whmapi1 unset_all_service_proxy_backends username=cpanelusername
    0
  • tonyotonio
    "whmapi1 unset_all_service_proxy_backends username=cpanelusername " still doesnt remove .htaccess entries and results in 502 error / redirect page being shown
    0

Please sign in to leave a comment.