Skip to main content
cPanel Technical Support has been heavily impacted by hurricane Beryl and our ability to respond to tickets has been hindered as a result. We appreciate your understanding and patience as we address these delays.

Mail stuck in outbox or sending multiple copies

Comments

29 comments

  • scottrichardson
    Additional information: It appears that clients using Microsoft Outlook are the ones who seem to be sending multiple copies of an email that's stuck in the outbox. I am assuming Outlook is repeatedly trying to send the email over and over again - and it IS sending, but NOT syncing the outbox/sent status? Further, I had a client who is having issues attempt to log into webmail and send an email. He could log in, and send me an email (my email is on the same server, too), but received a small red error in the bottom right of RoundCube webmail interface: SMTP Error: [-1] To confirm, when I use Terminal to ping my email server host name, it is reporting: Request timeout for icmp_seq 0 But I am still able to visit the WHM interface no problem via a browser.
    0
  • scottrichardson
    Update... Could it be too do with max. emails per hour per domain? ALL of my clients connect to the host name for their outgoing smtp email server, which also happens to have its own cPanel account. Could it be that cumulatively, all of their emails exceeded the max. per hour limit, which caused the bizarre behaviour? Even though they have their own mailboxes on their own cPanel accounts, they all use the one outgoing mail server which is the host name.
    0
  • microvax
    What versions of CPanel and Outlook are you using? I also received reports of the same behaviour yesterday early in the morning. The problem dissapeared during the day but appeared again today.
    0
  • cPRex Jurassic Moderator
    Hey there! I'm wondering if this is related to a problem with the server time that we found in case CPANEL-36312. Can you try restarting Exim manually to see if that gets things working well on the system?
    0
  • Bob Busch
    What versions of CPanel and Outlook are you using? I also received reports of the same behaviour yesterday early in the morning. The problem dissapeared during the day but appeared again today.

    Update... Could it be too do with max. emails per hour per domain? ALL of my clients connect to the host name for their outgoing smtp email server, which also happens to have its own cPanel account. Could it be that cumulatively, all of their emails exceeded the max. per hour limit, which caused the bizarre behaviour? Even though they have their own mailboxes on their own cPanel accounts, they all use the one outgoing mail server which is the host name.

    This sounds like the same problem as I am having. A client has started reporting issues with webmail daily. It started a few days ago and seems to happen around the same time of a cpanel update. When the problem starts, users have trouble sending email. After trying to send a message, the webmail hangs and eventually comes back with an SMTP Error. In order to resolve the issue, I attempted a system reboot which worked. Around the same time the next day the issue happened again, I rebooted again and it was resolved. I noticed that the cpanel update was happening mid day in Pacific time around the same time that the error started. I changed the cron job to have the updates take place in the middle of the night. The next day, the issue was reported in the morning. This morning I checked and saw the issue was happening again. After doing some research I tried updating the settings in the exim configuration manager which also restarts the exim config manager. After I did that the problem went away. So it seems that restarting exim makes the issue go away. I didn't make any configuration changes in the last few days which is why I suspected it had to do with a cpanel update. I tried to analyze the logs to see if I could see any error logging but I did not see any. When the problem is happening I have also heard of some users getting duplicate email messages for email sent internally within the same domain. I confirmed that by restarting exim the problem is (temporarily) resolved. My server OS and Cpanel version: CENTOS 7.9 hyper-v [vps].
    0
  • cPRex Jurassic Moderator
    @Bob Busch - that does sound a lot like CPANEL-36312. More details on that can be found here:
    0
  • microvax
    Today we received again reports of this issue after several days of no problems, and as mentioned by others resetting the EXIM service seems to solve the problem. BTW I also noticed several error messages in EXIM log files with this text "failed: Connection reset by peer"
    0
  • cPRex Jurassic Moderator
    @microvax - that would be case CPANEL-36312. We're working on it and planned to have that fixed both in 94 and 96.
    0
  • Kenric Ashe
    This seems like a huge issue considering how many cPanel users there are worldwide. It was reported March 20th. Why is it taking so long for the Exim devs to fix it? And while we're waiting, should cPanel release an emergency update with an Exim rollback?
    0
  • cPRex Jurassic Moderator
    @Kenric Ashe - it's important to note this isn't affecting all cPanel users. If there was a massive Exim issue affecting all cPanel machines, that would have caused incredibly widespread issues and there would have been an emergency fix in place. The issue only seems to happen when there is a time adjustment on the server by the chrony daemon, which seems to confuse Exim. We hope to have the fixes out in 94 and 96 soon.
    0
  • Kenric Ashe
    systemctl disable chronyd Might that be a better solution than periodically restarting Exim? Or is the use of chrony recommended?
    0
  • Bob Busch
    @Bob Busch - that does sound a lot like CPANEL-36312. More details on that can be found here:
    0
  • Bob Busch
    The issue has recurred and I have some more information. It seems like if exim is slow to respond, the problem occurs.. Not sure what is causing exim to be slow to respond.
    0
  • cPRex Jurassic Moderator
    @Bob Busch - if you restart Exim, does the issue resolve itself for a period of time?
    0
  • Bob Busch
    Yes.. restarting exit fixes the issue for a period of time. Not sure what causes it to recur. I am resisting restarting exim right now so we can troubleshoot. The problem continues.
    0
  • cPRex Jurassic Moderator
    Even though you may not see an entry for chrony in the logs, it still seems like it's related to that case. If you'd like to submit a ticket to our team we'd be happy to check things on our end.
    0
  • Bob Busch
    Even though you may not see an entry for chrony in the logs, it still seems like it's related to that case. If you'd like to submit a ticket to our team we'd be happy to check things on our end.

    I created a new ticket: #94318257
    0
  • cPRex Jurassic Moderator
    Thanks for that - I'm currently following along with that ticket on my end now.
    0
  • JFWebDesign
    Here we are, the end of April and STILL no fix? Duplicate emails, emails sitting in queues, Outlook time-outs. To expect us to reboot Exim every few hours to make sure our clients don't have email problems is NOT a fix nor is it a bandaid. What is the update on this? Also, there was never a response to the user who said:
    0
  • cPRex Jurassic Moderator
    If your system is affected and you can confirm it's because of the time change, disabling chrony may be a good option for you.
    0
  • JFWebDesign
    If your system is affected and you can confirm it's because of the time change, disabling chrony may be a good option for you.

    I can't confirm that it's because of a time change because I have no idea. I can just confirm that the overall issue is affecting six clients of mine and has been for months..
    0
  • Kenric Ashe
    If your system is affected and you can confirm it's because of the time change, disabling chrony may be a good option for you.

    How do we confirm whether chrony is the cause? Just disable it and see what happens? Is there any risk from disabling chrony? Surely it serves a purpose, but how critical is it? And what JFWebDesign said, why is the fix taking so long?
    0
  • Kenric Ashe
    Update! CPANEL-36312 is reportedly solved in v96.0.1!
    0
  • Kenric Ashe
    Update! CPANEL-36312 is reportedly solved in v96.0.1!

    I tried updating WHM/cPanel and it's still v94.0.5. How long does it take for updates to propagate?
    0
  • guilherme.matias
    A customer has a similar problem, when trying to send e-mails via roundcube the error occurs: "SMTP Error: [-1]", or via e-mail manager, there is a timeout in outgoing mail. When we restart exim, shipping will start again normally, but after a maximum of 2 days the problem will return. It is already in version 96.0.1 of whm/cpanel (last) but the problem persists, is there any forecast for resolution? Thanks.
    0
  • cPRex Jurassic Moderator
    @Kenric Ashe - CPANEL-36312 is fixed in 96.0.1. The updates may not happen instantly on your machine depending on your update settings in WHM, or our update distribution delay. Did you see a warning about the update being delayed in the logs? If not, you likely just aren't running the Current release. You can see where each of our tiers are at here:
    0
  • Kenric Ashe
    ... you likely just aren't running the Current release.

    Ah yes well I prefer the STABLE tier because I don't like my production server being a guinea pig, but I'll make an exception for this since it's a major bug fix. By the way, funny thing about STABLE or especially LTS (which at this moment are both v94.0.5) is that it's supposed to be "well-tested and proven", but 94.0.5 apparently was neither well tested nor proven. Ha! Anyhoo thanks for the tip!
    0
  • sparek-3
    Apparently this isn't going to be fixed in cPanel 94? Or maybe it has, and it's just not mentioned in cPanel 94's changelog? Kind of defeats the purpose of making cPanel 94 an LTS if it's not going to receive bug fixes. The point about STABLE and LTS releases not supposing to be vulnerable to things like this is valid. Now... obviously, I don't expect STABLE and LTS to have no bugs - and anybody that does really isn't being reasonable. There's always going to be some that creep through the cracks. But, if you look at things, it took until cPanel 94 reached STABLE/LTS before all of the tainting issues with Exim 4.94 to come to light. That should tell you something. That should tell you that nobody that ran a business was running cPanel 94 and Exim 4.94 in a production environment prior to cPanel 94 reaching STABLE/LTS. But the broader picture here is that cPanel has WAY, WAY, WAY too many versions to handle. And a lot of those versions aren't being used or aren't being used for the purpose they were designed for. You've got idiots running EDGE and CURRENT and God knows what versions and they have no idea how to look for bugs or to report bugs. Or you've got no idiots running EDGE or CURRENT and if that's the case, what's the point of EDGE and CURRENT? cPanel needs to take a good, long, hard look at their versioning system and revamp things. If you want idiots to find bugs for you, then you're going to have to incentivize them. Most of us run businesses in webhosting with cPanel as a tool. We don't have time to constantly be bugged with unfixed bugs and programming errors - we want a product that's going to work. I would propose having two versioning systems: STABLE or LTS and COLORFULSHINYBUTTONSANDNEWFEATURES Security and bugfixes get applied to both STABLE and COLORFULSHINYBUTTONSANDNEWFEATURES New shiny buttons only get applied to COLORFULSHINYBUTTONSANDNEWFEATURES Although... I think you'll find that most people will prefer STABLE over COLORFULSHINYBUTTONSANDNEWFEATURES - I could be wrong.
    0
  • cPRex Jurassic Moderator
    The specific case wasn't able to be backported, so the developers opened case CPANEL-36653 specifically to apply the same work to version 94. That has been included since 94.0.5. Are you still seeing issues with that version?
    0

Please sign in to leave a comment.