Skip to main content
cPanel Technical Support has been heavily impacted by hurricane Beryl and our ability to respond to tickets has been hindered as a result. We appreciate your understanding and patience as we address these delays.

Problem CPANEL-39824 : message has lines too long for transport - Since January 21, 2022

Comments

172 comments

  • daflame
    Same issue here!
    0
  • tinoandrijic
    Same issue!
    0
  • alinford
    Also having this issue
    0
  • cPRex Jurassic Moderator
    Thanks for reporting this - while we are aware of the issue, we don't have a workaround just yet. So far, it seems that most users experiencing the problem are using Outlook, as the same message is successfully sent through Webmail. If they have the option to do so, using Webmail instead of a client is a good, temporary workaround. We'll update that article once we have more details on the issue.
    0
  • tinoandrijic
    If they have the option to do so, using Webmail instead of a client is a good, temporary workaround.

    Easy with Outlook, the problem is with some of my clients who have a financial application that sends emails directly and that software is old and the developers are unavailable and the sent emails are pre-formatted. Unable to use webmail.
    0
  • daflame
    Thanks for reporting this - while we are aware of the issue, we don't have a workaround just yet. So far, it seems that most users experiencing the problem are using Outlook, as the same message is successfully sent through Webmail. If they have the option to do so, using Webmail instead of a client is a good, temporary workaround. We'll update that article once we have more details on the issue.

    Emails with this issues are sent using the mail() PHP function through websites. Not with Outlook.
    0
  • mickael
    Yes it is my case, mail() of PHP, it is the only concern that I encounter. I would not put any smtp system with login and password, because too long to create that, it is up to mail() of PHP which must work correctly.
    0
  • mickael
    I just did a quick test on a small php file: [CODE=php]$sujet = "Confirmation inscription"; $emailserver = "no-reply@name.com"; ini_set("sendmail_from",$emailserver); $entete = "MIME-Version: 1.0\n"; $entete .= "Content-type: text/html; charset=utf-8\n"; $entete .= "From: name.com <$emailserver>\r\n"; $entete .= "Return-Path: $emailserver\r\n"; $entete .= "Reply-To: $emailserver\r\n"; $params = sprintf("-oi -f %s",$emailserver); $template = file_get_contents('https://site.com/emails/theme1/email.php?email=my_email_test@yahoo.fr&confirm_id=fff&nick=fffff'); mail("my_email_test@yahoo.fr", $sujet, $template, $entete, $params);
    The email is not sent, the reason is: message has lines too long for transport Here is another test: [CODE=php]\r\n"; $entete .= "Return-Path: $emailserver\r\n"; $entete .= "Reply-To: $emailserver\r\n"; $params = sprintf("-oi -f %s",$emailserver); //$template = file_get_contents('https://site.com/emails/theme1/email.php?email=my_email_test@yahoo.fr&confirm_id=fff&nick=fffff'); mail("my_email_test@yahoo.fr", $sujet, "testt", $entete, $params);
    There the email is sent! The only thing changed is the "testt" message here: mail("my_email_test@yahoo.fr", $sujet, "testt", $entete, $params); Maybe there is a problem for the message part? is it limited? or it no longer accepts large html data nor templates
    0
  • ppwicho
    Any update CPANEL?.
    0
  • daflame
    I just did a quick test on a small php file: [CODE=php]$sujet = "Confirmation inscription"; $emailserver = "no-reply@name.com"; ini_set("sendmail_from",$emailserver); $entete = "MIME-Version: 1.0\n"; $entete .= "Content-type: text/html; charset=utf-8\n"; $entete .= "From: name.com <$emailserver>\r\n"; $entete .= "Return-Path: $emailserver\r\n"; $entete .= "Reply-To: $emailserver\r\n"; $params = sprintf("-oi -f %s",$emailserver); $template = file_get_contents('https://site.com/emails/theme1/email.php?email=my_email_test@yahoo.fr&confirm_id=fff&nick=fffff'); mail("my_email_test@yahoo.fr", $sujet, $template, $entete, $params);
    The email is not sent, the reason is: message has lines too long for transport Here is another test: [CODE=php]\r\n"; $entete .= "Return-Path: $emailserver\r\n"; $entete .= "Reply-To: $emailserver\r\n"; $params = sprintf("-oi -f %s",$emailserver); //$template = file_get_contents('https://site.com/emails/theme1/email.php?email=my_email_test@yahoo.fr&confirm_id=fff&nick=fffff'); mail("my_email_test@yahoo.fr", $sujet, "testt", $entete, $params);
    There the email is sent! The only thing changed is the "testt" message here: mail("my_email_test@yahoo.fr", $sujet, "testt", $entete, $params); Maybe there is a problem for the message part? is it limited? or it no longer accepts large html data nor templates

    I was able to solve the problem by adding line breaks in the message (not
    ). The entire email message was on one line only and it contained HTML code so it was a very long line of text.
    0
  • cPRex Jurassic Moderator
    We're discussing a few options to handle this on our end. I can't really say much more than that at this point, but it is in active development right now as this is a major issue.
    0
  • cPRex Jurassic Moderator
    Update - our team is currently testing a fix for version 102. Older versions will not need to be patched as they will still be using Exim 4.94 and the issue only comes up with systems using Exim 4.95. I'll post more details as I get them.
    0
  • linkedla
    Is getting complicated with some customers, I need help please.
    0
  • cPRex Jurassic Moderator
    The fix for version 102 is being tested today, and if all goes well with that testing it will get released soon.
    0
  • sgrzy01
    Any update? I have customers getting very upset at this point...
    0
  • Steve Kemp
    Ia m assuming given its Monday now that it hasn't gone well as i see no updates out yet? We have had clients with this issue screaming at us for over a week now... and they can't understand why we can't just fix it...
    0
  • Secmas
    Hope the fix is released soon. A lot of my customers are experiencing the same issue as well. Customers that have cams that send emails with pictures when an intrusion is triggered are suffering with this.
    0
  • cPRex Jurassic Moderator
    Update - our team is planning to push the fix to the next version of 102 later today. I'll post another message once that does officially happen.
    0
  • Secmas
    Thanks for the update, I will be waiting for your news.
    0
  • cPRex Jurassic Moderator
    Update - this will be in 102.0.2
    0
  • Steve Kemp
    changelog has come out for 102.0.2 but i notice its not available for download?
    0
  • alfonsofp
    When this 102.0.2 update will be available for download? Is there an ETA? . I need something to calm my customers... Please.
    0
  • cPRex Jurassic Moderator
    Update - 102.0.2 is now in Edge
    0
  • mickael
    The update would be available in 'Current' version from when? For update as soon as possible.
    0
  • cPRex Jurassic Moderator
    We haven't yet decided when this will move to Current.
    0
  • mickael
    @cPRex I'd love to upgrade to Edge but it says it's not recommended to use it in production, and also it'll be hard to go back to "Current" next time. Already that "Release" I can't take it anymore because I can't go back to an older version, I should have taken that, it would avoid falling on bugs like that :/ The email bug has been there since January 21, for almost 10 days!
    0
  • cPRex Jurassic Moderator
    Definitely don't upgrade to Edge on a production system. It's best to wait for this to clear to Current.
    0
  • mickael
    @cPRex Ok
    0
  • Reado
    What's happening with the update? We need it right now as this is having a huge impact on every email our server sends. Is there anything we can do to work around the issue, such as rolling back to a previous version, until the update is moved into the CURRENT branch?
    0
  • cPRex Jurassic Moderator
    There is never a supported way to downgrade cPanel. Servers being used in a production environment should at least be on Release or a more stable tier, and this issue only affected Current and Edge. The best thing to do at this time is to wait until the fix moves into Current.
    0

Please sign in to leave a comment.