Skip to main content
cPanel Technical Support has been heavily impacted by hurricane Beryl and our ability to respond to tickets has been hindered as a result. We appreciate your understanding and patience as we address these delays.

Wont redirct to https:// no matter what I do.

Comments

10 comments

  • kodeslogic
    Based on the information shared I would start by checking the ping response for the site.com and www.site.com is from the same IP address. From my experience, many times I have found client points site.com to the correct IP but www.site.com points to some other IP.
    0
  • 360webfirm
    same IP, just pinged. I just set up a new domain on another account for testing in c panel and all works perfect. This is really getting me so stressed as I have been on this for 6 hours and c panel responsed once several hours ago, and nothing since and I sent over several replies. Not sure whats up with that, but not very happy with the service and I have 10 servers with these guys. I checked permissions to htaccess and home dir, all good. Not sure wkat else to do, as I have never seen this before.
    0
  • 360webfirm
    just to note, the ONLy thing I did a week ago was add an addon domain to same c panel account, this add on domain works fine, but main domain for that one c panel account just wont work unless directly going to https://. Someone will really make my day if they can help me figure this out. Not a very good easter trying to fix a clients site. :(
    0
  • 360webfirm
    anyone have any other ideas?
    0
  • 360webfirm
    goes to page cgi-sys/defaultwebpage.cgi when using only www.site.com and just started about a week or so ago.
    0
  • andrew.n
    So a couple of questions here: 1. In WordPress under General Settings what is the exact site URL you have set? 2. Please ping
    0
  • Spirogg
    Try to rebuild Apache config with: /scripts/rebuildhttpdconf then restart Apache

    I think this should work as @andrew.n has pointed out... above or From the command line: /scripts/rebuildhttpdconf /scripts/restartsrv_httpd or /scripts/rebuildhttpdconf service httpd restart also are you using dns1 dns2 could anyone of your dns have been changed? when you added the add on domain does it use the same IP ans your domain reg domain. do you have another ns1 dns2 for the add on domain ? could check if all is ok with your registrar as well.
    0
  • 360webfirm
    Yep that is exactly what it was as I did this yesterday and just seen your repsonses now. C panel actually got back to me and said it was known this issue.
    0
  • Spirogg
    Yep that is exactly what it was as I did this yesterday and just seen your repsonses now. C panel actually got back to me and said it was known this issue.
    0
  • 360webfirm
    Thanks do much! Never had I ever seen this and it took me a very long time to figure out with C Panels support.
    0

Please sign in to leave a comment.