Skip to main content
cPanel Technical Support has been heavily impacted by hurricane Beryl and our ability to respond to tickets has been hindered as a result. We appreciate your understanding and patience as we address these delays.

php: time limit exceeded `Operation canceled' @ fatal/cache.c/GetImagePixelCache/1717

Comments

15 comments

  • splaquet
    UPDATE: I figured I'd run wp-cli using ROOT account, simply working around the time limit and updating file owner/group of regenerated thumbnails. I found this error rather odd, as I haven't seen this error before: [23-May-2022 17:14:25 UTC] PHP Warning: PHP Startup: Unable to load dynamic library 'imagick.so' (tried: /opt/cpanel/ea-php74/root/usr/lib64/php/modules/imagick.so (libMagickWand-6.Q16.so.6: cannot open shared object file: No such file or directory), /opt/cpanel/ea-php74/root/usr/lib64/php/modules/imagick.so.so (/opt/cpanel/ea-php74/root/usr/lib64/php/modules/imagick.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
    0
  • cPRex Jurassic Moderator
    Hey there! cPanel doesn't install any of the ImageMagick or MagickWand tools by default, so you'd need to manually add those to the system to get them working. Details on how to take care of that can be found here:
    0
  • laxbobber
    Following.... we are seeing this error in our nightly WHMCS cron runs: php: time limit exceeded `Operation canceled' @ fatal/cache.c/GetImagePixelCache/1716
    Probably the wrong place for this (as it's WHMCS-related) but a similar error. It doesn't happen every day for us so I'm still working through it. @splaquet did you work through it?
    0
  • splaquet
    @splaquet did you work through it?

    I haven't, and it doesn't sound as though cPanel staff is going to offer much more support on the issue. While I know that I already had ImageMagick installed (and libs) and previously working, I did go through their cPanel ImageMagick install guide to be safe. But nope... still seeing the same problem. The odd part is that this NEVER happened, and it only started happening recently. I have zero idea as to what changed, but something definitely did.
    0
  • cPRex Jurassic Moderator
    @splaquet - feel free to submit a ticket and we can check it out!
    0
  • Mark Donne
    Hi @splaquet We have today been notified by a user that they are also experiencing this same problem which started around 1 month ago. php-cgi: time limit exceeded `Operation canceled' @ fatal/cache.c/GetImagePixelCache/1717. Like you we have CloudLinux, although it's v7.9.0, LiteSpeed EWS and we use Imunify 360. Did you submit a ticket with cPanel and if so, did they find the cause?
    0
  • splaquet
    Did you submit a ticket with cPanel and if so, did they find the cause?

    Mark, I have not submitted a ticket.
    0
  • cPRex Jurassic Moderator
    @Mark Donne - feel free to submit a ticket!
    0
  • Mark Donne
    Hi We did submit a ticket in the end and a very helpful Cody Selzer managed to track down what we believe is the cause of the short timeout. I will copy and paste his response here for anyone else who encounters this problem. [QUOTE]You may attempt modifying the imagemagick policy, timeout. You can do this editing the file here: /opt/alt/alt-ImageMagick/etc/ImageMagick-7/policy.xml grep 120 /opt/alt/alt-ImageMagick//etc/ImageMagick-7/policy.xml
    We increased our value to 480 and the user who originally reported a problem said that they did not get any errors this morning. Hope this helps someone else.
    0
  • cPRex Jurassic Moderator
    @Mark Donne - thanks for sharing!
    0
  • splaquet
    grep 120 /opt/alt/alt-ImageMagick//etc/ImageMagick-7/policy.xml

    Thank you Mark! After editing and implementing that change, my issue immediately went away. Rex... sounds like something that pushed through from CloudLinux? My files were stamped 4/26, which is quite aligned with right around when I first discovered this issue. (I didn't post when I first noticed the problem, but came to the forums to post when it effected me the second time.) So, I'd have to assume this is limited to users of CL... and this file also had the same time/date stamp on all of my servers.
    0
  • cPRex Jurassic Moderator
    I've reached out to them to see if they have any other details on this - I'll let you know when I hear back!
    0
  • cPRex Jurassic Moderator
    CloudLinux did confirm they made this change because users had requested a timeout option, but they have an internal case open to see if there is a better way to handle that in the future. I can't share that case here because it's on the CloudLinux side of things, but they are aware and working on this now.
    0
  • splaquet
    CloudLinux did confirm they made this change because users had requested a timeout option, but they have an internal case open to see if there is a better way to handle that in the future. I can't share that case here because it's on the CloudLinux side of things, but they are aware and working on this now.

    thank you so much for helping out there. ...yeah, that change of theirs was NO BUENO!!!
    0
  • cPRex Jurassic Moderator
    It might be best to contact them directly to let them know how it is affecting you and your users so they have additional feedback.
    0

Please sign in to leave a comment.