Skip to main content
cPanel Technical Support has been heavily impacted by hurricane Beryl and our ability to respond to tickets has been hindered as a result. We appreciate your understanding and patience as we address these delays.

Almalinux UPGRADE fails on reboot

Comments

7 comments

  • andrew.n
    NetworkManager installed?
    0
  • baronn
    NetworkManager installed?

    thats the funny thing. YES but: systemctl status NetworkManager results in: failed to start NetworkManager.service: Unit NetworkManager .service not found BUT the using: systemctl restart network it all starts working instantly! concerened that if the 'box' ever descideds to rebbot itself then it will be offline UNTIL we can run that: systemctl restart network again. Thats not ideal or workable...
    0
  • quietFinn
    What I did was: yum remove NetworkManager and then: systemctl enable network
    0
  • HostNoc
    HI systemctl stop NetworkManager systemctl disable NetworkManager service network restart Regards SAM
    0
  • quietFinn
    Better make sure that network is enabled if you run; systemctl is-enabled network you should get: network.service is not a native service, redirecting to /sbin/chkconfig. Executing /sbin/chkconfig network --level=5 enabled If it's not enabled it does not start after reboot.
    0
  • baronn
    What I did was: yum remove NetworkManager

    Doesnt actually do anything: No match for argument: NetworkManager Dependencies resolved. Nothing to do. Complete!
    systemctl enable network

    @quietFinn Thank you. This did it for me. Works a treat. Not sure why this isnt included (or maybe a bug?) when using eleavte to upgade? so I guess I will have to include this in steps for the other boxes we will be upgrading.
    HI systemctl stop NetworkManager systemctl disable NetworkManager service network restart Regards SAM

    @HostNoc As far as this goes it gives the output: systemctl stop NetworkManager Failed to stop NetworkManager.service: Unit NetworkManager.service not loaded. systemctl disable NetworkManager Failed to disable unit: Unit file NetworkManager.service does not exist. service network restart Restarting network (via systemctl): [ OK ] BUT it doesnt actually enable anything (weird even though the output says OK?)
    Better make sure that network is enabled if you run; systemctl is-enabled network you should get: network.service is not a native service, redirecting to /sbin/chkconfig. Executing /sbin/chkconfig network --level=5 enabled If it's not enabled it does not start after reboot.

    @quietFinn None of that helped APART from: systemctl is-enabled network which helped to identify IF it was enabled OR disabled when trying to get the darn thing to stay on
    0
  • quietFinn
    Starting (or restarting) network does not enable it, it must be enabled or networking does not start on boot. I know very little about networking, but this I have learned, with a little help from cPanel support.
    0

Please sign in to leave a comment.