Skip to main content
We are currently experiencing a higher than average ticket volume and as such our responses may be delayed. Searching on our Help Center articles or going to our Community is also a great resource for answers.

WordPress and PHP 8.1 UTF8MB4

Comments

5 comments

  • kodeslogic
    Which MariaDB version you are running?
    0
  • RicRey
    Which MariaDB version you are running?

    Thanks for replying, I'm using mariadb 10.6
    0
  • kodeslogic
    1.) Take the backup of /etc/my.cnf
    file using the below command. (In case anything goes wrong you can revert back) # cp /etc/my.cnf /etc/my.cnf-backup
    2.) Now edit the /etc/my.cnf and add the following: [client] default-character-set=utf8mb4 [mysql] default-character-set=utf8mb4 [mysqld] character-set-server=utf8mb4 character_set_client=utf8mb4 collation-server=utf8mb4_general_ci
    3.) Restart MariaDB server # systemctl restart mysqld
    0
  • RicRey
    I did the steps and added but it still appears, here I attach my file. # This group is read both by the client and the server # use it for options that affect everything # [client-server] # # include *.cnf from the config directory # !includedir /etc/my.cnf.d [client] default-character-set=utf8mb4 [mysql] default-character-set=utf8mb4 [mysqld] log-error=/var/lib/mysql/.cprapid.com.err performance-schema=0 innodb_buffer_pool_size=134217728 max_allowed_packet=268435456 open_files_limit=40000 innodb_file_per_table=1 unix_socket=OFF character-set-server=utf8mb4 character_set_client=utf8mb4 collation-server=utf8mb4_general_ci
    0
  • kodeslogic
    Check if switching the domain to alt-php81 with PHP native nd_mysqli
    module enabled resolves the problem.
    0

Please sign in to leave a comment.