Skip to main content
cPanel Technical Support has been heavily impacted by hurricane Beryl and our ability to respond to tickets has been hindered as a result. We appreciate your understanding and patience as we address these delays.

Configured cron-jobs not displayed on Cpanel > Cron Jobs [case CPANEL-6197, fixed in 56.0.17]

Comments

32 comments

  • chiareu
    seams that is an error after recent update and need to log via ssh and run chmod 4755 /usr/bin/crontab
    0
  • cPanelMichael
    Hello :) Internal case CPANEL-5479 is open to address an issue where the permissions of /usr/bin/crontab on CentOS/RHEL/CloudLinux 7.x systems are automatically changing to 0755 instead of 4755. The temporary workaround is to set the permission values with the following command:
    rpm --setperms cronie
    I'll update this thread with more information as it becomes available. Thank you.
    0
  • Zaheer Ahmad Khan
    Hello, i am running a server (with root access), but all my (cpanel) users can't create cron jobs I get the following error while creating cron job You ($user) are not allowed to use this program (crontab) See crontab(1) for more information I verified crontab is checked in respective feature list & unchecked in disable feature list.
    0
  • Zaheer Ahmad Khan
    Thank you Michael, rpm --setperms cronie
    fixed the issue Kind Regards
    0
  • maestroc
    I am on a dedicated server with root access. The individual user accounts however cannot add cron jobs despite them being enabled and appearing in the user's cpanel. They are allowed to enter in the information but when saving the crontab it gives the error of: You ($user) are not allowed to use this program (crontab) See crontab(1) for more information I have followed the instructions found on this page: Cron job error and ran the following command on the server via SSH: rpm --setperms cronie but the problem persists. Do I need to restart something to make it take effect? What other steps do I need to take to allow users to create cron jobs?
    0
  • SysSachin
    Hi, The provided error showing that the user not allow to run cron. Can you please try to add username in the /etc/cron.allow file by run below command. echo USERname > /etc/cron.allow This will create the new cron.allow file and add user account to that file. Once this is done you can utilize crontab as normal.
    0
  • maestroc
    I did as instructed. I no longer get that error but instead I get this one: /var/spool/cron/#tmp.server.coremap.com.XXXXFnwfpK: Permission denied
    0
  • Joseph Waite
    Hello :) Internal case CPANEL-5479 is open to address an issue where the permissions of /usr/bin/crontab on CentOS/RHEL/CloudLinux 7.x systems are automatically changing to 0755 instead of 4755. The temporary workaround is to set the permission values with the following command:
    rpm --setperms cronie
    I'll update this thread with more information as it becomes available. Thank you.

    Any update on this. I am having similar issue, However the above does not fix it. After running the above I get the following error. Permission on "/usr/bin/crontab" are wrong (4755). Please set to 4755. Which is strange as its basically saying there wrong so please set to what they already are!!
    0
  • cPanelMichael
    Any update on this. I am having similar issue, However the above does not fix it. After running the above I get the following error. Permission on "/usr/bin/crontab" are wrong (4755). Please set to 4755. Which is strange as its basically saying there wrong so please set to what they already are!!

    The internal case is still open at this time. Could you also try running "/scripts/upcp --force" to see if that addresses the issue after running the previous command suggested earlier in this thread? Note: I've merged all posts from other threads related to this issue here. Thank you.
    0
  • Joseph Waite
    The internal case is still open at this time. Could you also try running "/scripts/upcp --force" to see if that addresses the issue after running the previous command suggested earlier in this thread? Thank you.

    Yeah I have just done this. And I can see my cron jobs again. Existing ones which had disappeared have re-appeared. Will update after midnight to see if they actually run now.
    0
  • Joseph Waite
    Yeah I have just done this. And I can see my cron jobs again. Existing ones which had disappeared have re-appeared. Will update after midnight to see if they actually run now.

    Ok It is now showing me the cron jobs from the web interface, however it does not actualy run them.
    0
  • cPanelMichael
    Ok It is now showing me the cron jobs from the web interface, however it does not actualy run them.

    Are the permissions on /usr/bin/crontab set to 4755 on this system? Also, I encourage anyone experiencing this issue to open a support ticket using the link in my signature and reference case CPANEL-5479. We have yet to reliably reproduce the issue, so avoid attempting a manual resolution if possible, so we can see your system in the broken state. Thank you.
    0
  • cPanelMichael
    Hello, Additional testing shows the issue relates to Cpanel::Cron::Utils operating on the wrong binary. CPANEL-5479 will ensure this is automatically corrected, however until that case is released, please run this command manually and let us know if it prevents the issue from reoccurring:
    /usr/local/cpanel/3rdparty/bin/perl -MCpanel::Cron::Utils -e 'Cpanel::Cron::Utils::run_crontab("args"=>["-l">)'
    Thank you.
    0
  • cPanelMichael
    Hello, The resolution stemming from CPANEL-5479 is now available as part of cPanel 54.0.14: Fixed case CPANEL-5479: Autofix the system binary crontab permissions if they are incorrect. You can update to the new build via "/scripts/upcp" over the command line, or through Web Host Manager (WHM Home >> cPanel >> Upgrade to Latest Version). Feel free to update this thread if the issue continues. Also, note if you notice an error message when accessing the "Cron Jobs" option on the X3 theme, a separate thread is open at: X3 cron jobs Thank you.
    0
  • Deker
    I'm running cpanel/whm 56(build 16) on my CentOS dedicated server. Today I found that all of my cpanel cron jobs are disappeared and also can not add new cron jobs. It's strange because all cron jobs are working fine as I checked in my cms. I did all the suggested solutions that mentioned above but the issue is still persists. I also tried X3 theme. Please help!
    0
  • vipin
    Hi, Same issue here, It is for paper_lantern theme only.
    0
  • Deker
    Getting the following errors in Chrome Inspect element at cpanel cron jobs page:
    Uncaught TypeError: Cannot read property 'innerHTML' of null index.html:984 Uncaught TypeError: Cannot read property 'Minute' of undefined master-legacy.cmb.min.js:13
    0
  • vbroot
    Same issue here, It is for paper_lantern theme and x3, for all customer in one server Cpanel latest 56.0.16 yesterday it's working Today not see any crons in Current Cron Jobs also not possible create new cron joobs
    0
  • PatrickVeenstra
    I've already tried:
    rpm --setperms cronie
    The cron jobs don't show up in CPanel, and I'm unable to edit the cron jobs email address. Javascript log (Chrome)
    index.html:1040 Uncaught TypeError: Cannot read property 'innerHTML' of null 2016-05-17 12:22:19.923 master-legacy.cmb.min.js:13 Uncaught TypeError: Cannot read property 'Minute' of undefined 2016-05-17 12:22:27.018 require.min.js:8 Uncaught Error: Load timeout for modules: master/master.dist http://requirejs.org/docs/errors.html#timeout 2016-05-17 12:22:38.024 https://cpanel.webdd.eu/frontend/paper_lantern/_assets/master.dist.min.js?version=1463442782 Failed to load resource: net::ERR_CONNECTION_TIMED_OUT 2016-05-17 12:22:38.025 require.min.js:8 Uncaught Error: Script error for: master/master.dist http://requirejs.org/docs/errors.html#scripterror
    Both the old and the new theme have this issue.
    0
  • rpvw
    I am seeing the same issues as well /etc/redhat-release:CloudLinux Server release 6.7 (Aleksei Gubarev) /usr/local/cpanel/version:11.56.0.16 /var/cpanel/envtype:standard CPANEL=release Server version: Apache/2.4.18 (Unix) Server built: May 10 2016 13:13:01 Cpanel::Easy::Apache v3.32.13 rev9999 +cloudlinux PHP 5.5.35 (cli) (built: May 10 2016 13:15:03) Copyright (c) 1997-2015 The PHP Group Zend Engine v2.5.0, Copyright (c) 1998-2015 Zend Technologies with the ionCube PHP Loader v4.7.5, Copyright (c) 2002-2014, by ionCube Ltd. mysql Ver 14.14 Distrib 5.6.30, for Linux (x86_64) using EditLine wrapper
    0
  • TuTiendaHosting
    I still have the same problem after running all scripts shown in this post and also after forcing the upgrade again. Thanks and regards.
    0
  • Gualter
    Hi I have the same problem... I have a cron created, but does not show in the Cpanel. Screens: prnt.sc/b54q42 prnt.sc/b54qn5 After runing all scripts it does not fixed my issue... Someone can help?
    0
  • Tsafarog
    Same issue here WHM 56.0 (build 16) I tried above solutions + force update and the issues persists Cron tasks are running but are not viewable in cpanel nor you add new ones Regards
    0
  • pyrographics
    I think this is a new bug because it started happening today with at least one of our servers as well. WHM 56.0 (build 16)
    0
  • Tsafarog
    i confirm for my server only papern_latern theme
    0
  • julienmru
    Same here on paper_lantern and 56.0.16.
    0
  • JohnMC
    Same here, just noticed today and it looks like cpanel updated last night. I use paper lantern theme and style for all my users and for me I can work around the issue by switching to the old style and theme, this is what I did and note the first step is not enough: 1) Change Style > Apply the "Retro" Theme 3) From home, change the "Switch Theme" drop-down to "x3" (left stats/widget area)
    0
  • JaredR.
    Hello! There is actually a known bug that is causing this problem. It affects the Cron Jobs page in Paper Lantern, but not in x3, in cPanel 56.0.16. The workaround for now is to change the account to use x3, temporarily, because the Cron Jobs page works correctly in that theme. You can change the theme for an account in the WebHost Manager, in Home " Account Functions " Modify an Account, or using the method that JohnMC described. Our developers are working on this and a fix is going through the Quality Assurance process right now. The plan is to publish it in cPanel 56.0.17. The internal case is CPANEL-6197, and that will be mentioned in the
    0
  • rpvw
    ) Change Style > Apply the "Retro" Theme 3) From home, change the "Switch Theme" drop-down to "x3" (left stats/widget area)

    I confirm that this does seem to work on 11.56.0.16
    0
  • rotame
    I had the same problem after changing to x3 working CENTOS 7 CLOUDLINUX 7.2 x86_64 standard " srv WHM 56.0 (build 16)
    0

Please sign in to leave a comment.