Skip to main content
cPanel Technical Support has been heavily impacted by hurricane Beryl and our ability to respond to tickets has been hindered as a result. We appreciate your understanding and patience as we address these delays.

Problems Upgrading from Centos7 to Almalinux8

Comments

8 comments

  • dscreative

    Thanks, I will do. Really do appreciate your help with this.

    1
  • cPanelPeter cPanel Staff

    Hello, 

    Could you try running the following and supplying the output:

    ls -al /sys/class/net

    and

    /sbin/ip addr

    Feel free to mask the actual IP addresses. 

     

    0
  • dscreative

    Really appreciate your help. The result is:

    # ls -al /sys/class/net
    total 0
    drwxr-xr-x  2 root root 0 Jan 17 13:55 .
    drwxr-xr-x 52 root root 0 Jan 17 13:55 ..
    lrwxrwxrwx  1 root root 0 Jan 17 13:55 eth0 -> ../../devices/pci0000:00/0000:00:03.0/virtio0/net/eth0
    lrwxrwxrwx  1 root root 0 Jan 17 13:55 eth1 -> ../../devices/pci0000:00/0000:00:08.0/virtio4/net/eth1
    lrwxrwxrwx  1 root root 0 Jan 17 13:55 eth2 -> ../../devices/pci0000:00/0000:00:09.0/virtio5/net/eth2
    lrwxrwxrwx  1 root root 0 Jan 17 13:55 eth3 -> ../../devices/pci0000:00/0000:00:0a.0/virtio6/net/eth3
    lrwxrwxrwx  1 root root 0 Jan 17 13:55 eth4 -> ../../devices/pci0000:00/0000:00:0b.0/virtio7/net/eth4
    lrwxrwxrwx  1 root root 0 Jan 17 13:55 lo -> ../../devices/virtual/net/lo

     

    and:

     

    # /sbin/ip addr
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
           valid_lft forever preferred_lft forever
        inet6 ::1/128 scope host
           valid_lft forever preferred_lft forever
    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
        link/ether 52:54:00:40:57:ce brd ff:ff:ff:ff:ff:ff
        inet x.x.x.x/24 brd x.x.x.x scope global eth0
           valid_lft forever preferred_lft forever
        inet6 fe80::5054:ff:fe40:57ce/64 scope link
           valid_lft forever preferred_lft forever
    3: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
        link/ether 52:54:00:57:de:34 brd ff:ff:ff:ff:ff:ff
    4: eth2: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
        link/ether 52:54:00:d0:c0:52 brd ff:ff:ff:ff:ff:ff
    5: eth3: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
        link/ether 52:54:00:57:de:34 brd ff:ff:ff:ff:ff:ff
    6: eth4: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
        link/ether 52:54:00:d0:c0:52 brd ff:ff:ff:ff:ff:ff

     

    It seems there are some more interfaces, but somehow hidden! Any idea how we can remove these extra ones. I don't believe they are needed.

    0
  • cPanelPeter cPanel Staff

    Hello,

    You can usually use the same /sbin/ip command to delete a device. I see they are already marked as being DOWN.  

    Reviewing the man page for ip, it seems you can use: 

    /sbin/ip link delete eth1

    If that's successful, you can then do the same for eth2 through eth4.

    DO NOT DO THIS FOR eth0 (obviously).

    If you have issues, you will need to consult with your system or network administrator.

     

    0
  • dscreative

    I tried this but it responds with:

    # /sbin/ip link delete eth1
    RTNETLINK answers: Operation not supported

    Any ideas? Is this something we need the people we purchased the VPS from to solve?

    0
  • cPanelPeter cPanel Staff

    Hello, 

    Yes, I would contact them and inquire how they set up their network. This is not something cPanel can assist with unfortunately. 

     

    0
  • ANZEEQ

    Hi need help,

    getting error:
    * 2024-05-26 07:16:27 (6513) [INFO] Error: Unable to find a match: ea-php56 ea-php56-build ea-php56-libc-client ea-php56-pear ea-php56-php-bcmath ea-php56-php-bz2 ea-php56-php-calendar ea-php56-php-cli ea-php56-php-common ea-php56-php-curl ea-php56-php-dba ea-php56-php-devel ea-php56-php-enchant ea-php56-php-exif ea-php56-php-fileinfo ea-php56-php-fpm ea-php56-php-ftp ea-php56-php-gd ea-php56-php-gettext ea-php56-php-gmp ea-php56-php-iconv ea-php56-php-imap ea-php56-php-intl ea-php56-php-ldap ea-php56-php-litespeed ea-php56-php-mbstring ea-php56-php-mysqlnd ea-php56-php-odbc ea-php56-php-opcache ea-php56-php-pdo ea-php56-php-pgsql ea-php56-php-posix ea-php56-php-process ea-php56-php-pspell ea-php56-php-soap ea-php56-php-sockets ea-php56-php-tidy ea-php56-php-xml ea-php56-php-zip ea-php56-runtime ea-php74-php-redis ea-php80-php-redis
    * 2024-05-26 07:16:27 (6530) [INFO]
    * 2024-05-26 07:16:27 (6421) [INFO] Sending notification: Failed to update to AlmaLinux 8
    * 2024-05-26 07:16:27 (6426) [ERROR] The elevation process failed during stage 4.
    * 2024-05-26 07:16:27 (6426) [ERROR]
    * 2024-05-26 07:16:27 (6426) [ERROR] You can continue the process after fixing the errors by running:
    * 2024-05-26 07:16:27 (6426) [ERROR]
    * 2024-05-26 07:16:27 (6426) [ERROR]     /usr/local/cpanel/scripts/elevate-cpanel --continue
    * 2024-05-26 07:16:27 (6426) [ERROR]
    * 2024-05-26 07:16:27 (6426) [ERROR] You can check the error log by running:
    * 2024-05-26 07:16:27 (6426) [ERROR]
    * 2024-05-26 07:16:27 (6426) [ERROR]     /usr/local/cpanel/scripts/elevate-cpanel
    * 2024-05-26 07:16:27 (6426) [ERROR]
    * 2024-05-26 07:16:27 (6426) [ERROR] Last Error:
    * 2024-05-26 07:16:27 (6426) [ERROR]
    * 2024-05-26 07:16:27 (6426) [ERROR] command failed. Fix it and run command. at /usr/local/cpanel/scripts/elevate-cpanel line 6491.
    * 2024-05-26 07:16:27 (8000) [FATAL] command failed. Fix it and run command. at /usr/local/cpanel/sc

    0
  • cPRex Jurassic Moderator

    ANZEEQ - you wouldn't be able to install PHP 5 on AlmaLinux 8, so that error is expected.  It would probably be best to update the PHP version on your local install, confirm that works well, and then run ELevate.

    0

Please sign in to leave a comment.