Skip to main content
cPanel Technical Support has been heavily impacted by hurricane Beryl and our ability to respond to tickets has been hindered as a result. We appreciate your understanding and patience as we address these delays.

How to disable the 8KB buffer in Apache/PHP-FPM on WHM?

Comments

4 comments

  • Benjamin D.

    After a few days of searching for solutions on the internet and reading all sorts of outdated, contradictory and over all vague and non conclusive threads on various forums, including Jeff Geerling's post on the topic, then not having a single mod_proxy_fcgi related answer on here after a day, I came to the conclusion that it simply cannot be done with that Apache mod, at least not without a doctorate in computer science lol.

    That's a shame, but then I realized that there was a not so cumbersome solution I could implement in just a couple minutes and that it would not even require any sort of Apache configuration at all! I'll share it here for future visitors:

    1) Just add a subdomain that points to the same public_html directory in cPanel

    2) Disable PHP-FPM on that subdomain in WHM.

    3) There's no step 3!!!

    It's gonna run using suphp just like it did for a decade on the old server... and we're back to fully functional PHP scripts with no output buffer for scripts called via that subdomain.  Problem solved! New technology is just so bizarre sometimes.  It's like nothing is thought through like it was in the past, but thank god that old technology is still supported (suphp).

    Hope it helps somebody else lose less hair than I did.

    EDIT: I thought for a second that it did not work, but it works :) It's truly hybrid depending on which subdomain I'm requesting the web page from.  Just PERFECT.

     

    1
  • Benjamin D.

    Unfortunately, that's already what it's set to and this has no effect for PHP-FPM.  It only has an effect for suphp which is the PHP handler I have to use for those domains where I need output buffering turned off.  I'm specifically asking for turning off output buffering for PHP-FPM.

    0
  • MilesWeb

    Hello,

    You can simply login to WHM >  MultiPHP INI editor > Select the PHP version > Go to Editor mode > turn off the OutPutBuffering.

     

    -1
  • Ifinitive host

    Hello,

    You can simply login to WHM >  MultiPHP INI editor > Select the PHP version > Go to Editor mode > turn off the OutPutBuffering.

    -1

Please sign in to leave a comment.