Skip to main content
cPanel Technical Support has been heavily impacted by hurricane Beryl and our ability to respond to tickets has been hindered as a result. We appreciate your understanding and patience as we address these delays.

DNS Stopped Working For Remote Domains



  • cPRex Jurassic Moderator

    Hey there!  A cPanel update wouldn't make any changes to the DNS zone, so it would seem unlikely to be related to the issue.

    I'd start troubleshooting this like any other DNS issue - if you use an online tool like, what does that tell you?  Can it reach the nameservers at all?  Do the nameservers respond to ping/dig?  If so, do they respond to a direct query like this?


    Working through standard DNS troubleshooting should point you to the issue.

  • verdon

    cPRex thanks. I did resolve this yesterday, but haven't had a chance to follow up here yet. I'm still not sure what caused the failure, but I'll post the resolution in case it helps someone down the road. I need to provide a little background first...

    These domains are part of a migration from an old server to a new server (with new IP addresses). The bulk of the migration was done quickly and easily using the cPanel migration tools (thank you for those) a couple weeks ago. A handful of domains were left on the old server to give them a little extra time to deal with their dependance on php7, which I am not offering on the new server. Since my nameservers and authoritative DNS were moving to the new server, I had to deal with that. What I did was take a copy of the respective zone files from /var/named on the old server and placed them in /var/named on the new server. I then changed a few TTLs using the DNS Zone Manager on the new server, and everything has been working fine for nearly a month.

    What I finally did yesterday that got them working again, was to just pretend to change a TTL on one of the problematic zones on the new server, saving that non-change, which forced the zone file to reload into the DNS server, and the zone started resolving immediately again. I did this for each of the problematic zones and all is well.

    So, this leads me to speculate that the DNS service restarted for some reason and that there is an internal database I am not aware of that tells it what zones in /var/named to load.

    In any case, this was a band-aid to allow me to move the DNS for all clients from old to new, while leaving a couple of accounts on old for a period of time. I'll be able to use the cPanel migration tools soon to move the rest of the accounts, and my band-aid will no longer be necessary. I'm still not sure why this happened, and would welcome any thoughts you have, but all is well for now.

  • cPRex Jurassic Moderator

    Thanks for the details - there wouldn't be a database involved, but in general copying DNS zones doesn't work well because of what you found - the main TTL or serial number in the zone could be older than a previous entry.  I bet what was happening was that the new server had an older serial number, causing DNS propagation to fail or stop, and then once you made the change the serial number was also updated (which happens automatically every time a zone is adjusted) got the data working properly on the new machine.


Please sign in to leave a comment.