Skip to main content

upcp on Almalinux9 fails due to update package

Comments

13 comments

  • chirpy

    There is a workaround that I've been using:

    yum update --enablerepo epel-testing

    The problem is that they've rebuilt ImageMagick but it hasn't made it yet from their EPEL testing repo to the live one yet.

    Note: The command above will update from AlmaLinux v9.3 to v9.4

    1
  • chirpy

    Yeah, I tried it on Rocky Linux today and couldn't get it to work either. Only on AlmaLinux v9

    1
  • webo3com

    On CloudLinux 9 I was able to make it work by doing this :

    yum update --enablerepo=cloudlinux-rollout-2-bypass
    yum update
    1
  • cPRex Jurassic Moderator

    Hey there!  This is a known issue with AlmaLinux that we have reported to them, but unfortunately there is no workaround at this time.  You can follow along with this case for updates on the issue as we'll post more details once we have them:

    https://support.cpanel.net/hc/en-us/articles/23295663571607-Almalinux-9-includes-newer-libraw-r-so-23-and-Imagick-wants-20

    0
  • pixelweb

    cPRex 

    We're encountering the same error today on a freshly built VPS, along with another issue related to iptables-libs.

    2024-05-07 05:54:09 -0700]      [/usr/local/cpanel/scripts/update-packages]  Problem 2: cannot install both iptables-libs-1.8.10-2.el9.x86_64 from baseos and iptables-libs-1.8.8-6.el9_1.x86_64 from @System
    [2024-05-07 05:54:09 -0700]      [/usr/local/cpanel/scripts/update-packages]   - package iptables-legacy-1.8.8-6.el9.2.x86_64 from @System requires (iptables-libs(x86-64) = 1.8.8-6.el9 or iptables-libs(x86-64) = 1.8.8-6.el9_1), but none of the providers can be installed

    Hopefully this gets resolved. 

    0
  • cPRex Jurassic Moderator

    pixelweb - I'm not aware of the iptables issue at this time - is this also on AlmaLinux 9?

    0
  • toyama

    Thank you for your comments.
    I will try the workaround you suggested.

    0
  • Guile

    I'm also having something similar. This is on rocky-release-9.3-1.3.el9.noarch.

    I tried yum update --enablerepo epel-testing and dnf --enablerepo=epel-testing install ImageMagick ImageMagick-libs but I still get:

    Last metadata expiration check: 0:25:39 ago on Wed 08 May 2024 03:51:07 PM EDT.
    Error:
     Problem 1: cannot install the best update candidate for package ImageMagick-libs-6.9.12.93-1.el9.x86_64
      - nothing provides libraw_r.so.23()(64bit) needed by ImageMagick-libs-6.9.12.93-2.el9.x86_64 from epel
     Problem 2: package ImageMagick-devel-6.9.12.93-2.el9.x86_64 from epel requires ImageMagick-libs(x86-64) = 6.9.12.93-2.el9, but none of the providers can be installed
      - cannot install the best update candidate for package ImageMagick-devel-6.9.12.93-1.el9.x86_64
      - nothing provides libraw_r.so.23()(64bit) needed by ImageMagick-libs-6.9.12.93-2.el9.x86_64 from epel
     Problem 3: package ImageMagick-6.9.12.93-2.el9.x86_64 from epel requires ImageMagick-libs(x86-64) = 6.9.12.93-2.el9, but none of the providers can be installed
      - cannot install the best update candidate for package ImageMagick-6.9.12.93-1.el9.x86_64
      - nothing provides libraw_r.so.23()(64bit) needed by ImageMagick-libs-6.9.12.93-2.el9.x86_64 from epel
    (try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

    0
  • Guile

    Thanks, but I tried: dnf --enablerepo=epel-testing install ImageMagick ImageMagick-libs

    No luck.

    0
  • cPRex Jurassic Moderator

    That's odd - I haven't had anyone else tell me that hasn't worked, but I'm also not sure I've had anyone try this on Rocky yet.  They could be affected by this also and have a different fix necessary.  You can always submit a ticket so we can check.

    0
  • webo3com

    It didn't work for me also. I'm using CloudLinux 9.

    0
  • toyama

    When an error occurred, AlmaLinux 9.3 had ImageMagick already installed on .

    In my case, I used 'dnf update' to exclude ImageMagick and LibRaw, and updated 9.3 to 9.4.
    After that, when I performed 'dnf update', the ImageMagick package was successfully updated.


    AlmaLinux 9.3 -> 9.4

    dnf update --exclude="ImageMagick* LibRaw*"

    ImageMagick update

    dnf update
    0

Please sign in to leave a comment.