Skip to main content
We are currently experiencing a higher than average ticket volume and as such our responses may be delayed. Searching on our Help Center articles or going to our Community is also a great resource for answers.

GD php extension

Comments

14 comments

  • cPRex Jurassic Moderator

    Hey there!  The easiest way to confirm what modules are loaded is to create a PHP Info page on your site that you can visit in a browser.  This will show all of your PHP configurations and settings on that site.  Details on how to create that can be found here:

    https://support.cpanel.net/hc/en-us/articles/360052760494-How-to-use-a-PHPInfo-file-for-troubleshooting-PHP-issues

    Specifically you are looking for a section partway down the page that looks similar to this:

    0
  • Alessandro Porcu

    GD section is not present but in EA the modules is installed. This is the issue.

    0
  • cPRex Jurassic Moderator

    What happens if you run this command - does it show that GD is compiled?

    /usr/bin/ea-php81 -i | grep -i gd

     

    0
  • Alessandro Porcu

    same for php 8.1

    0
  • Alessandro Porcu

    --enable-gd=shared

    0
  • cPRex Jurassic Moderator

    That's interesting - I'm not sure why it would be marked as enabled but also not show up.  It might be best to create a ticket with our team so we could take a look at that, as I don't have a good explanation for that behavior.

    0
  • Alessandro Porcu

    I have noticed that 

    editing the profile of EAapache, there is the list only of installed php modules and not for all available modules.

    0
  • cPRex Jurassic Moderator

    That's add, as when you use the "Customize" button it should show you all the available options for the server.  Are you able to run "yum update" normally on the machine?

    0
  • vorple

    Seeing the same behaviour in sites here. The ea-php**-php-gd packages are installed, gd is showing in the configure as "--enable-gd=shared', the gd.so extension is in the modules directory (same permissions/ownership as other working extensions), but it doesn't work and doesn't show in phpinfo Configuration section. Tried with 8.1, 8.2 and 8.3. Not working in all three.

    Ubuntu 22.04, Cpanel 120.0.9

    ea-php82-php-common/unknown,now 8.2.20-1+3.1.cpanel amd64 [installed]
    ea-php82-php-gd/unknown,now 8.2.20-1+3.1.cpanel amd64 [installed]
    ea-php82/unknown,now 8.2.20-1+2.1.cpanel amd64 [installed]

     

    0
  • cPRex Jurassic Moderator

    vorple- could you create a ticket so this can be investigated? 

    0
  • vorple

    Some more info from the logs:

     PHP Warning:  PHP Startup: Unable to load dynamic library 'gd.so' (tried: /opt/cpanel/ea-php82/root/usr/lib64/php/modules/gd.so (libavif.so.13: cannot open shared object file: No such file or directory), /opt/cpanel/ea-php82/root/usr/lib64/php/modules/gd.so.so (/opt/cpanel/ea-php82/root/usr/lib64/php/modules/gd.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0: /usr/local/cpanel/cgi-sys/ea-php82

    Note gd.so.so for some reason.

    0
  • cPRex Jurassic Moderator

    Ah, well that shows us an actual issue then.  I'd try reinstalling PHP 8.2 completely and see if that changes the behavior.

    0
  • vorple

    Working here now after installing libavif13 and it's dependencies, and restarting httpd.

    apt installed: libabsl20210324 libavif13 libgav1-0 libyuv0

    And it now works as expected.

    0
  • cPRex Jurassic Moderator

    I would guess it was the "and it's dependencies" that got thins working, but glad to hear things are well!

    0

Please sign in to leave a comment.