Skip to main content

WHM update fails, Cloudlinux AccelerateWP conflict



  • Andrew

    Have you tried to update the CL release file first?

    yum update cloudlinux-release

    the run yum update again.

    Andrew N. - cPanel Plesk VMWare Certified Professional
    Do you need immediate assistance? 20 minutes response time!* Open a ticket
    EmergencySupport - Professional Server Management and One-time Services

  • User404
    yum info cloudlinux-release
    Installed Packages
    Name        : cloudlinux-release
    Arch        : x86_64
    Version     : 7.9
    Release     : 2.3.el7
    Size        : 60 k
    Repo        : installed
    From repo   : cloudlinux-rollout-1
    Summary     : CloudLinux release file
    License     : GPLv2
    Description : CloudLinux release files
    yum update cloudlinux-release
    No packages marked for update

    I never ran the "yum update cloudlinux-release" before, but it's already installed.

  • cPRex Jurassic Moderator

    If you aren't using it, there's no reason you can't remove that tool using the instructions here:

    which will likely resolve the issues you're seeing.

  • User404

    Thank you for the reply.

    I executed the command and seems like it disabled the AccelerateWP system wide and from all users.


    Next, I tried "yum update" which said the same error message about the package conflict. After that, I removed the accelerate-wp package completely. I ran "yum remove accelerate-wp", which removed the package and a few dependencies from the system.

    After the package was gone, the yum update was successful.

    So, the problem is solved for me, but the original problem is still there. The AccelerateWP has some kind of package conflict. Removing AccelerateWP won't resolve the conflict issue, this solution is only by passing the problem.

    I guess there are WHM admins out there who are running Cloudlinux 7.9, and they are using the AccelerateWP package. I hope someone resolves the package conflict.

  • cPRex Jurassic Moderator

    It might be best to submit a ticket on this issue, as I'm not finding any similar reports on this package conflict in our system.

  • gatewayza

    Hi CPRex, 

    I have a system that has the same problem. 

    [2024-05-16 07:52:50 +0200]      [/usr/local/cpanel/scripts/update-packages] --> Processing Conflict: accelerate-wp-1.9-12.el7.cloudlinux.x86_64 conflicts alt-python27-cllib < 3.4.2-2
    [2024-05-16 07:52:50 +0200]      [/usr/local/cpanel/scripts/update-packages] --> Finished Dependency Resolution
    [2024-05-16 07:52:50 +0200]      [/usr/local/cpanel/scripts/update-packages] Error: accelerate-wp conflicts with alt-python27-cllib-3.4.1-1.el7.cloudlinux.x86_64
    [2024-05-16 07:52:50 +0200]      [/usr/local/cpanel/scripts/update-packages] Error: Package: accelerate-wp-1.9-12.el7.cloudlinux.x86_64 (cloudlinux-rollout-4)

    So it is not isolated to User404. 

  • User404

    Update to my situation. So I did remove the accelerate-wp package from the system as said earlier. Then we upgraded the whole system to Cloudlinux 8. After that, I tried to re-install the accelerate-wp package again and it's still causing the error. The same thing, dependency conflict. So this might include Cloudlinux 8 as well.


Please sign in to leave a comment.