Cause
The issue commonly occurs when the InnoDB logfiles have become corrupt. Moving the files out of the data directory will force the files to be rebuilt.
Symptoms
When accessing a table in phpMyAdmin, you receive the following error.
CONFIG_TEXT: 1286 - Unknown storage engine 'InnoDB'
You will also see entries similar to the following in the MySQL/MariaDB error log.
CONFIG_TEXT: [ERROR] Could not open mysql.plugin table: "Unknown storage engine 'InnoDB'". Some plugins may be not loaded
[ERROR] Can't open and lock privilege tables: Unknown storage engine 'InnoDB'
Resolution
Warning: Do not move or delete ib_logfile0 on these versions. Doing so will stop MariaDB from starting.
As of MariaDB 10.8.1, the various ib_logfile* files are now a critical part of the database storage engine. As such, if these files have become corrupted, or are no longer on the server, the files will need to be restored from a backup.
How to restore the Entire MySQL Directory from cPanel system backups
Additional Information
- Access the server's command line as the 'root' user via SSH or "Terminal" in WHM.
-
Create a storage directory for the files.
# mkdir /root/innodb.bak
-
Stop the SQL service.
# /usr/local/cpanel/scripts/restartsrv_mysql --stop
-
Move the log files to the storage directory.
# mv -v /var/lib/mysql/ib_logfile* /root/innodb.bak/
-
Start the SQL service.
# /usr/local/cpanel/scripts/restartsrv_mysql --start
Comments
0 comments
Article is closed for comments.