Skip to main content
cPanel Technical Support has been heavily impacted by hurricane Beryl and our ability to respond to tickets has been hindered as a result. We appreciate your understanding and patience as we address these delays.

Webmail Login Success But Redirect to Roundcube Login Page

Comments

13 comments

  • andrew.n
    so what you want to achieve here? Do you want to change the password of the email account? You can do it from RoundCube and also from cPanel if you go to Email Accounts and instead of Check email you click on Manage.
    0
  • cPanelLauren
    That autologin feature relies on cookies to complete, it sounds like it's saving the old session when you're attempting to log into the new account. I'm curious if loosening cookie IP validation in Tweak Settings would resolve this
    0
  • nisi
    try out this too...
    0
  • scottrichardson
    I'm having this issue too with one particular email address. I have tried the fixes posted above including loosening cookie ip validation, along with deleting the cube.db file for the account, all to no avail. Any help is greatly appreciated.
    0
  • cPRex Jurassic Moderator
    @scottrichardson - if the issue is just with one email address, it seems more likely to be a browser issue than something on the server. If you try a different browser does the issue still happen?
    0
  • r1nk0
    @scottrichardson - if the issue is just with one email address, it seems more likely to be a browser issue than something on the server. If you try a different browser does the issue still happen?

    Yes it does it happens on different devices we cant login to one user but 50+ rest works fine. I can see in headers its sending expired cookies
    0
  • cPRex Jurassic Moderator
    @r1nk0 - can you get me more details on what you're seeing happening with your situation? This original thread is a few years old, so any additional details you have would be helpful.
    0
  • r1nk0
    @r1nk0 - can you get me more details on what you're seeing happening with your situation? This original thread is a few years old, so any additional details you have would be helpful.

    Hey @cPRex thanks for replying, so what exactly was happening after the cpanel got updated to version 108.0.13 two of email accounts had this issue. User goes to webmail url and logins there and we see green notification Login success and then it redirects to index.php asking to login again. We are using Roundcube. So I went for headers first and I saw that once login was success instead setting correct headers it would set headers to expire in 2-3sec. I went instantly to check roundcube "config.inc.php" file I know I changed $config['session_lifetime'> = 10; //minutes so i though maybe on update was changed back, but that was fine. What I did later is I went in WHM->Tweak settings and disabled Cookie IP validation and nothing was happening still same issue with those two mailboxes. Then I went and changed $config['session_lifetime'> = null; restarted exim and nothing worked none of the mailboxes. After that i changed it back to $config['session_lifetime'> = 10; restarted exim and it all started working. What I don't understand is why was this happening to only to two email accounts and the rest of them worked perfectly fine. I would really like to know what could cause this so I could prevent it from happening again. I really hope I was clear enough and you could understand what is going on here. Thank you.
    0
  • cPRex Jurassic Moderator
    I'm honestly not sure what would have caused that behavior. I can say that restarting Exim wouldn't have had an affect on this as Exim isn't related to the webmail connection at all, unless you're actively sending a message. All that is handled by the Dovecot server and the webmail tool itself. It seems like the session_lifetime value is the most likely culprit here. I can confirm that "10" is the default value on a stock cPanel server in this file.
    0
  • r1nk0
    I'm honestly not sure what would have caused that behavior. I can say that restarting Exim wouldn't have had an affect on this as Exim isn't related to the webmail connection at all, unless you're actively sending a message. All that is handled by the Dovecot server and the webmail tool itself. It seems like the session_lifetime value is the most likely culprit here. I can confirm that "10" is the default value on a stock cPanel server in this file.

    Yes it looked to me like the session_lifetime was not read correctly or smth. But all good now. If it happens again I will submit a ticket so you guys can check it out exactly why it's happening. Thank you for everything @cPRex
    0
  • cPRex Jurassic Moderator
    That sounds like a plan!
    0
  • r1nk0
    That sounds like a plan!

    Can I submit a ticket so someone can take a look at it. It just happen again with one mailbox the rest are working fine. EDIT: @cPRex just to update you I found what was going on nothing to do with configuration or anything. That one mailbox was was constantly being attacked by bruteforce so cPHulk was locking it down. I have blocked the attack and whitelisted our office IPS now everything works perfectly fine. Thank you for pointing dovecot to me thats where I went to see the logs and was able to narrow it down. I need to buy you a beer.
    0
  • cPRex Jurassic Moderator
    I'm glad that got you pointed in the right direction! But yes, you're always welcome to open a ticket with our team if you have root access to the server.
    0

Please sign in to leave a comment.