Skip to main content
cPanel Technical Support has been heavily impacted by hurricane Beryl and our ability to respond to tickets has been hindered as a result. We appreciate your understanding and patience as we address these delays.

Using the new DDNS feature

Comments

35 comments

  • cPRex Jurassic Moderator
    Hey there! I can't say that I'm familiar with this requiring a user or password. The only tools we have available on the cPanel side is the creation of the URL that would be provided to the service you're accessing. Since cPanel has no knowledge of the user and password you're entering on the router side, we may not be able to work properly with that specific device. I did check the configuration guide here:
    0
  • ddaddy
    No, i've tried all the settings. Is it not possible to just tell Cpanel to ignore the Auth header?
    0
  • cPRex Jurassic Moderator
    At this time there aren't any additional configuration options for the DDNS tools. That might make a good feature request though!
    0
  • ddaddy
    Ok, I"ll switch back to my existing setup for now. If all that"s required is visiting the URL, then maybe ignoring both the auth header and any added params, it should then work with DD-WRT.
    0
  • spiral2
    I am also trying to use this feature. But I don't know how to call the uri generated. It generated the url in the url "https:///cpanelwebcall/. How is this URL supposed to get called, some pointer at documentation would be nice. I want to run a script on my linux system that call the above uri. Thanks @cPRex
    0
  • ddaddy
    I think just a simple GET request will do. Try putting the url into a web browser and see if it updates the IP.
    0
  • spiral2
    Well I did that in Postman and in the browser. But it sends me a 400 or a 404 (depends on what I try): This is from the ssl_log from the cpanel interface: - - [] "GET /cpanelwebcall/ HTTP/1.1" 404 - "-" "PostmanRuntime/7.26.3"
    The response I received in Postman without useful information in the response headers: 400 Bad Request

    Bad Request

    Your browser sent a request that this server could not understand.

    Additionally, a 400 Bad Request error was encountered while trying to use an ErrorDocument to handle the request.


    In the errors page from the cpanel interface I can't find anything related. This is my config. The version used is 92.0.5
    0
  • cPRex Jurassic Moderator
    @spiral2 - can you let me know what steps you've taken up until that point so I can test this on my end?
    0
  • alepaes
    Same problem here - 404 not found. In fact, CPanel should not provide such a resource with this poor documentation.
    0
  • cPRex Jurassic Moderator
    @alepaes - if you can provide me details on where you are getting stuck I'm happy to help get the documentation updated or made more clear.
    0
  • spiral2
    I followed this guide. Dynamic DNS | cPanel & WHM Documentation 1. Go to my hosting provider 2. Signin 3. Go to cPanel v.92.0.5 (theme paper_lantern) 4. Click on Dynamic DNS 5. Click on Create 6. Fill in the field `Dynamic DNS DOMAIN` a. subdomain name: home b. The domain dropdown is disabled because there's only one domain available 7. Click on Create 8. Green messages popup that it is created 9. Automatic redirect to the Dynamic DNS overview 10. Verify a. Domain is filled correctly b. IP Address is `None` c. URL is created in format `https:///cpanelwebcall/`. (domain != subdomain) d. SSL Certificate is viewable 10. Click on the COPY button 11. Open Google Chrome Browser. 12. Press F12 for the Developer Console. Go to the Network Tab 13. Paste in the URI in the `Addressbar` of the browser 14. Press `Enter` 15. Verify the respone. a. Status code 404 is returned b. The response is: 404 Not Found

    Not Found

    The requested URL was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    16. If we go back to step 10.b We won't see the IP-Address filled

    0
  • ddaddy
    I just tested mine and it works fine. I created a new ddns domain. At this point, no A record was added to the dns. I copied the generated URL and pasted it into safari and hot go. It showed me my IP and now there was an A record with my ip address.
    0
  • alepaes
    @alepaes - if you can provide me details on where you are getting stuck I'm happy to help get the documentation updated or made more clear.

    Hi cPRex, The most common use of DDNS is with a user and password. This is an example of ddclient config: use=web, web=checkip.dynu.com/, web-skip='IP Address' # Get ip from server. server=api.dynu.com # IP update server. protocol=dyndns2 login=abc@gmail.com # Your username. password=abc # Password or MD5/SHA256 of password. myrouter.ddnsgeek.com # List one or more hostnames one on each line. In this case, ddclient go to
    0
  • cPRex Jurassic Moderator
    @alepaes - thanks for the detailed reply. Would you happen to be doing this work on a CloudLinux system? If so, can you check out our article here to see if that helps with your situation?
    0
  • alepaes
    @alepaes - thanks for the detailed reply. Would you happen to be doing this work on a CloudLinux system? If so, can you check out our article here to see if that helps with your situation?
    0
  • cPRex Jurassic Moderator
    Great - I'm glad that worked for you!!!
    0
  • spiral2
    @cPRex is this a fault in that release or is there a setting that my hostingprovider must set before I can use this feature.
    0
  • cPRex Jurassic Moderator
    @spiral2 - since you don't have root access you wouldn't be able to try that workaround I posted above. It would be best to ask your host about this issue to see if they can either get that resolved or perform the workaround I mentioned for you on their end.
    0
  • spiral2
    Ok. I will bring this workaround to their attention. Can you also confirm this is a bug in this release and it should work out-of-the-box?
    0
  • cPRex Jurassic Moderator
    The issue I outlined is only happening CloudLinux systems or other machines that are out of date. If there are additional things happening with your system, we'd need more investigation to determine the cause.
    0
  • spiral2
    I pointed my hosting provider to this thread and they applied the workaround. Now it works. They said they were on a recent CloudLinux version. Thanks @cPRex and @alepaes for pointing and testing the workaround.
    0
  • cPRex Jurassic Moderator
    @spiral2 - I'm glad that is working for you now!
    0
  • Hedloff
    It helped us too, but first request gives 200. But second or third gives 500 Internal Server Error. Any idea how to fix this?
    0
  • cPRex Jurassic Moderator
    @Hedloff - currently there isn't a way to fix that, but our developers are working on it now!
    0
  • Hedloff
    So you know you have made a new feature, well not new anymore... And know that its not working at all, anywhere and still launch it anyway? Why not Just remove it when nothing works! And you guys use the time to focus on new gui without icons.......
    0
  • Hedloff
    Customer was able to use this webcall before:
    0
  • cPRex Jurassic Moderator
    @Hedloff - currently there isn't a workaround for the error happening after the call has been used once. Is this the error you're reporting in the other thread you have opened? I'm not sure what errors you're seeing with the IP address so I haven't been able to do my testing.
    0
  • Hedloff
    Updated the other thread with manual IP function not working when creating dynamic DNS. So nothing about Dynamic DNS is actually working. So get it prioritized and fixed, or just remove the whole feature as it's just causing support for us from our customers.
    0
  • cPRex Jurassic Moderator
    I'll check the other thread and get you more details there.
    0
  • Hedloff
    Any update on this bug aswell? Could you please update this page:
    0

Please sign in to leave a comment.