Skip to main content
cPanel Technical Support has been heavily impacted by hurricane Beryl and our ability to respond to tickets has been hindered as a result. We appreciate your understanding and patience as we address these delays.

CPANEL-38866 - How to exclude multiple domains of multiple cPanel accounts from AutoSSL via SSH

Comments

8 comments

  • cPRex Jurassic Moderator
    Hey there! The closest thing I would have would be this API call:
    0
  • Inna
    Hey there! The closest thing I would have would be this API call: www.ip.domain.com
  • www.mail.com The issue with the above command is that the respond is OK, but only the domain in the first parameter (in this case, it is www.domain.com is exluced. The doc says domain=domain=example.com domain1=example1.com domain2=example2.com
    but the syntax is wrong and if I run this command I get this error: [root@fqdn ~]# whmapi1 --output=jsonpretty add_autossl_user_excluded_domains username='user' domain=domain=www.ip.domain.com domain1=www.domain.com { "metadata" : { "reason" : "API failure: (XID 42pcds) You do not own the following domain: domain=www.ip.domain.com.", "command" : "add_autossl_user_excluded_domains", "version" : 1, "result" : 0 } }
  • 0
  • Inna
    Delete this post please:) I see DST Root CA X3 Expiration and Let's Encrypt to update the certificates, but I'm curious about how this API works with multiple domains
    0
  • cPRex Jurassic Moderator
    Well sure enough, that's happening on my end as well. I'm looking into this now and I'll update you soon.
    0
  • cPRex Jurassic Moderator
    I've created a case with our team to look into that API behavior. If you're signed in to our system, you can follow along with
    0
  • cPRex Jurassic Moderator
    Update - we've fixed the typo and updated the command so it actually works. Check it out here: Disable AutoSSL for domain " cPanel & WHM Developer Portal
    0
  • Inna
    Thanks, it works now:)
    0
  • cPRex Jurassic Moderator
    I'm glad to hear that's working well!
    0

Please sign in to leave a comment.