Skip to main content

CPANEL-40545 - No brute force protection detected while Imunify360 active

Comments

17 comments

  • cPRex Jurassic Moderator
    Hey there! I created a v102 test server and did the following: -confirmed that cPanel's Brute Force Protection is enabled by default -turned off cPHulk -installed Imunify360 -went back to the Security Advisor page and I see "Your server is protected by Imunify360" but I do not see the brute force protection warning. At this point I'm not able to reproduce the issue you're seeing, so it might be best to create a ticket with our team so we can check that particular system.
    0
  • Duplika
    We are using CloudLinux 8.5, just restarted Imunify 360, tried enabling / disabling Bruteforce protection... even server has been restarted but the warning stays.
    0
  • cPRex Jurassic Moderator
    I was able to reproduce this on a CloudLinux machine. I've got a case incoming and I'll update soon!
    0
  • cPRex Jurassic Moderator
    I've created case CPANEL-40545 with our developers and I'll be sure to post an update here once I have details to share.
    0
  • cPRex Jurassic Moderator
    Update: We've done some research on this and found that i360 does what cPHulk does and both do not need to be enabled. Security Advisor still needs to be adjusted to correctly detect i360.
    0
  • AzeDK
    Update: We've done some research on this and found that i360 does what cPHulk does and both do not need to be enabled. Security Advisor still needs to be adjusted to correctly detect i360.

    Any ETA on when it will be fixed?
    0
  • cPRex Jurassic Moderator
    I actually show this is resolved in version 112 - are you still seeing the issue?
    0
  • AzeDK
    I actually show this is resolved in version 112 - are you still seeing the issue?

    You are correct, its fixed in 112, but it reports the wrong software (We use Imunify360): Your server is protected by ImunifyAV.
    0
  • cPRex Jurassic Moderator
    That would be a separate issue, then, as CPANEL-40545 was saying Imunify of any type wasn't valid protection. Displaying the correct version you have installed would be a different detection option, but still something we can fix. I couldn't make this happen on my personal system just now, so could you submit a ticket to our team so we can see this problem in action?
    0
  • AzeDK
    That would be a separate issue, then, as CPANEL-40545 was saying Imunify of any type wasn't valid protection. Displaying the correct version you have installed would be a different detection option, but still something we can fix. I couldn't make this happen on my personal system just now, so could you submit a ticket to our team so we can see this problem in action?

    95100399
    0
  • cPRex Jurassic Moderator
    Thanks for that - I see Aaron is working on that now!
    0
  • cPRex Jurassic Moderator
    It looks like the issue was actually a setting inside your cPanel Store account inside Manage2 that our team was able to track down through the ticket.
    0
  • AzeDK
    It looks like the issue was actually a setting inside your cPanel Store account inside Manage2 that our team was able to track down through the ticket.

    I don't see any confirmation on that yet, its stuck with Ryland for now.
    0
  • cPRex Jurassic Moderator
    On our side it looks like we're assuming this is closed, so if you're still seeing issues please send us a reply.
    0
  • AzeDK
    On our side it looks like we're assuming this is closed, so if you're still seeing issues please send us a reply.

    I'd still consider it a bug, as I dont see why i have to sell Imunify360 licenses through the cpanel store, just to use the security advisor.
    0
  • cPRex Jurassic Moderator
    I agree - can you include that in the ticket too?
    0
  • cPRex Jurassic Moderator
    Update - this will be backported to 110.
    0

Please sign in to leave a comment.