Skip to main content
cPanel Technical Support has been heavily impacted by hurricane Beryl and our ability to respond to tickets has been hindered as a result. We appreciate your understanding and patience as we address these delays.

DNSOnly install fails

Comments

18 comments

  • quietFinn
    cPanel & WHM only support AlmaLinux, Rocky, and Cloudlinux 9 on version 112 or greater.

    By default cPanel installs the RELEASE version which is currently 110, If you want 112 you must install the EDGE version, like this: open file /etc/cpupdate.conf and in that file write: CPANEL=edge and run the install. It might work, but last time i tried (not long ago) it didn't :rolleyes:
    0
  • cPRex Jurassic Moderator
    What @quietFinn said - cPanel only supports version 9 in the Edge tier, so you have to customize the installation a bit to make that happen.
    0
  • kernow
    I never selected any version, just ran the default installation script. Also, /etc/cpupdate.conf does not exist. This is a new server with AlmaLinux 9 freshly installed. I only ran curl -o latest-dnsonly -L https://securedownloads.cpanel.net/latest-dnsonly sh latest-dnsonly
    0
  • quietFinn
    If /etc/cpupdate.conf does not exists you must create it. That is the only way to install the EDGE version.
    0
  • kernow
    Not looking to install the edge version, just the default.
    0
  • mtindor
    Not looking to install the edge version, just the default.

    Then you will have to wait until 112 is in Release before you attempt it. As mentioned, Almalinux 9 isn't supported in WHM 110 or earlier, and the default DNSOnly install is going to want to install the Release version (currently 110).
    0
  • kernow
    So I should have installed AlmaLinux 8 to get the default 110 version, I see now. Tried installing edge which almost completed but failed with: 62] (FATAL): The background process "Install YUM universal hooks" failed with a fatal error: The subprocess reported error number 127 when it ended. 2023-04-21 14:00:57 44 [2682] ( INFO): cPanel is here to help! Our Technical Support team is just a click away at https://support.cpanel.net/ or you can contact Customer Service via email cs@cpanel.net 2023-04-21 14:00:57 127 [2682] (FATAL): The system failed to run the /usr/local/cpanel/scripts/cpanel_initial_install script. [root@ns324620 ~]# /usr/local/cpanel/scripts/cpanel_initial_install
    0
  • mtindor
    So I should have installed AlmaLinux 8 to get the default 110 version, I see now.

    Probably so, as much of a bummer as that is. I recently deployed a new hosting box and was bummed that I either had to wait for WHM 112 (and hope there were zero bugs with Almalinux9) or had to install Almalinux8. I obviously ended up installing Almalinux8 even though it would have made much more sense to use Almalinux9 from the standpoint of Almalinux 8 Active Support ending in May 2024 vs Almalinux 9 Active Support ending in May 2027. I just get the feeling that this will end up being another case where cPanel stops supporting / blocks updates to newer versions of WHM before the Almalinux 8 Security Supports ends in 2029. M
    0
  • kernow
    I think this is cpanel's fault as nowhere on the install requirements does it say DNSOnly won't install on AlmaLinux 9. OK, so I reformatted the OS and installed AlmaLinux 8, alas it almost completed but halted with 'Failed to Install YUM universal hooks'. I can now create a ticket as it installed a temp licence so at least some progress on what should have been a straight forward install. Thanks to those who posted advice :)
    0
  • cPRex Jurassic Moderator
    That does seem odd - I'd expect the A8 installation to work just fine. Since you submitted a ticket, could you post that number here so I can follow along?
    0
  • kernow
    Sure, Ticket #95047916
    0
  • cPRex Jurassic Moderator
    Thanks - I'm following along now!
    0
  • kernow
    All working OK now. It seems "nearly all of the cPanel packages had some problem installing" cPanel Bill Bailey was able to rectify the errors.
    0
  • cPRex Jurassic Moderator
    I'm glad we were able to help get that working!
    0
  • Steve Kemp
    Ive tried a new install of 9 on a new machine this morning and it refuses to install i was told by support to set the release to CURRENT in cpupdate.conf before running the installer but it returns an error saying: (FATAL): The specified tier ('CURRENT') in the /etc/cpupdate.conf file is not a valid cPanel & WHM tier. so no idea what's going on there.... i also note that once the installer starts running before the FATAL it wipes the contents of cpupdate.conf
    0
  • Steve Kemp
    ok turns out they should have told me to set it to CPANEL=current and not CPANEL=CURRENT
    0
  • quietFinn
    0
  • ujakeysnakey
    I had this error trying to install CPanel latest on AlmaLinux 8.8 I was able to work around it by re-installing AlmaLinux 8.8 but not adding any hostame to the setup. Ie. leave it as localhost.localhost. then run the CPanel install. here is the exact error I had but it"s ok now. [QUOTE]The background process "EA4 Install" failed with a fatal error: The subprocess reported error number 127 when it ended.
    Cheers Jake
    0

Please sign in to leave a comment.