Skip to main content
cPanel Technical Support has been heavily impacted by hurricane Beryl and our ability to respond to tickets has been hindered as a result. We appreciate your understanding and patience as we address these delays.

exim & dkim "tainted filename"

Comments

4 comments

  • MHFraser
    ah so its my 'smarthost based on sender domain' mod.
    0
  • MHFraser
    fixed. for future googlers, exim needs to lookup the dkim keys, it wont accept a value from the email, so change these: require_files = "+/var/cpanel/domain_keys/private/${lookup{$sender_address_domain}dsearch{/var/cpanel/domain_keys/private/}}" dkim_private_key = "/var/cpanel/domain_keys/private/${lookup{$dkim_domain}dsearch{/var/cpanel/domain_keys/private/}}"
    0
  • cPRex Jurassic Moderator
    Thanks for sharing the fix!
    0
  • santrix
    When trying this fix on v110 cPanel - exim 4.96 #2 built 18-Jan-2023 12:40:24, we are seeing Error message from syntax check: 2023-09-28 09:02:24 cwd=/root 4 args: /usr/sbin/exim -bV -C /etc/exim.conf.buildtest.work.b533fc1b 2023-09-28 09:02:24 Exim configuration error in line 2655 of /etc/exim.conf.buildtest.work.b533fc1b: option "require_files" unknown In the end, we had to adopt mailchannel's fix of using dkim_domain = ${perl{get_dkim_domain}} to fool exim into thinking the dkim_domain variable isn't tainted.
    0

Please sign in to leave a comment.