Skip to main content
cPanel Technical Support has been heavily impacted by hurricane Beryl and our ability to respond to tickets has been hindered as a result. We appreciate your understanding and patience as we address these delays.

Cpanel account not showing in WHM-->listaccounts

Comments

20 comments

  • quietFinn
    After OS and cPanel installation there can't be any cPanel accounts, before you create them.
    0
  • SimpleSonic
    Prior to the reinstallation of Ubuntu and cPanel, did you have cPanel accounts on the server? If so, I hope you had a backup of those accounts because reinstalling the OS and cPanel would have completely wiped the server of any existing data.
    0
  • cPRex Jurassic Moderator
    What the other two users said - if you wiped the server and reinstalled cPanel, all your data would have been removed. If that isn't what happened and you are seeing a different scenario, please provide us with more details about how the serer got to this point.
    0
  • chasedeveloper
    I did wipe the server and reinstalled cPanel. How do I add a cPanel account again?
    0
  • SimpleSonic
    I did wipe the server and reinstalled cPanel. How do I add a cPanel account again?

    You would need to refer to your own backups to restore the accounts. Hopefully you were doing proper offsite backups as you should have been.
    0
  • chasedeveloper
    You would need to refer to your own backups to restore the accounts. Hopefully you were doing proper offsite backups as you should have been.

    I did not, so what can I do to make another account?
    0
  • chasedeveloper
    Am I just banned from cpanel because I didnt do the backup correctly? some clarification would be nice. there must be something I can do.
    0
  • cPRex Jurassic Moderator
    I'm not sure what "banned from cPanel" means. If you wiped the server, you would have lost all your data. Unless you took a backup, there wouldn't be any data you could access or restore. If you'd like to create a new account, you can do that from WHM: Create a New Account | cPanel & WHM Documentation
    0
  • chasedeveloper
    Is this the page you are referring to? If so I am unable to create an account here for some reason. I provided a screenshot.
    0
  • cPRex Jurassic Moderator
    Yes, that is the correct page. Are you logged in to WHM as root?
    0
  • chasedeveloper
    Yes, that is the correct page. Are you logged in to WHM as root?

    Correct
    0
  • cPRex Jurassic Moderator
    And just to extra confirm, your URL is similar to
    0
  • chasedeveloper
    This is the last part of the url I see on the WHM create new account page is".cprapid.com:2087/cpsess1459108674/scripts5/wwwacctform" this looks correct, except the "cprapid", not sure if that is important. I ran the "/scripts/upcp --force" command and updated the system. It did not fix the issue, unfortunately. I dont see any errors that look they could be coming from the "create new account" page. Is there one I should be looking for?
    0
  • quietFinn
    I think you should fix your server's hostname. xxx.cprapid.com looks like a temporary hostname cPanel assigns to your server, and it's possible it's not resolving correctly.
    0
  • cPRex Jurassic Moderator
    While you definitely should setup a proper hostname (
    0
  • chasedeveloper
    So I went ahead and I updated the host name in WHM-->network setup-->change hostname. I also changed the hostname in my VPS manager, Hostinger. Unfortunately I am still unable to create an account. Thanks for the help.
    0
  • cPRex Jurassic Moderator
    I would submit a ticket - if you're the root user, and this is showing up, there is something wrong with the system.
    0
  • chasedeveloper
    While you definitely should setup a proper hostname (
    0
  • chasedeveloper
    I would submit a ticket - if you're the root user, and this is showing up, there is something wrong with the system.

    is it this page with the url "
    0
  • cPRex Jurassic Moderator
    It sure is! Or you can do it through WHM >> Create a Suppor Ticket, if that area of the system is working.
    0

Please sign in to leave a comment.