Skip to main content
cPanel Technical Support has been heavily impacted by hurricane Beryl and our ability to respond to tickets has been hindered as a result. We appreciate your understanding and patience as we address these delays.

Subdomain redirecting incorrectly

Comments

5 comments

  • cPanelMichael
    Hello, You will need to ensure the "A" record for the subdomain is manually configured at your domain registrar pointing to the account's IP address. Or, simply configure your own custom name servers to avoid this requirement: [Tutorial] Nameserver configuration on cPanel servers Thank you.
    0
  • Thorsten H.
    I think, that is the wrong direction, the subdomain (shop.domain.tld) is working but when I call www.domain.tld I will be redirected to Default Web Site Page. If I call the domain with HTTPS I get an SSL-error and then I will be redirected to diff-domain.tld. I don't understand that. I have edited the DNS-entry and added shop. to the IP evan that *. is present.
    0
  • cPanelMichael
    Hello, Do you have "www.domain.tld" configured with an "A" record at your registrar pointing to the correct IP address? Regarding the issue with SSL, it's likely because that domain shares the same IP address with the other domain name on the same server. Thus, since no SSL certificate is installed on this domain, it automatically uses the first VirtualHost with a SSL certificate on the IP. Here's a document that explains how this happens: SSL FAQ and Troubleshooting - Documentation - cPanel Documentation. Thank you.
    0
  • Thorsten H.
    OK, by now I understand some thinks. To the background: I have 2 servers, an old and a new one. I have transfered the problem-domain to the new server; prior it was on the old one. So I only had to change the IP at the DNS of my registrar. On the old server every thing was fine; I could call the subdomain (shop.) and the domain by itself (www.domain.tld and domain.tld). After transfering the complete contend to the new server I changed the IP to the new one. After ca. 2 hours I could call the subdomain at the new server. But I could call the domain.tld all day, since I changed the adress. The problems with the domain changed; first the domain (www.domain.tld and domain.tld) where redirected to another domain on the old server that I host. And NOW??? Everything is fine again; it lasts a little bit longer to change :-( - thanks to you all and good night from germany.
    0
  • cPanelMichael
    Hello, I'm happy to see the issue is now resolved. Thank you for updating this thread with the outcome.
    0

Please sign in to leave a comment.