Skip to main content
cPanel Technical Support has been heavily impacted by hurricane Beryl and our ability to respond to tickets has been hindered as a result. We appreciate your understanding and patience as we address these delays.

mysql: [ERROR] unknown option '--ssl'

Comments

3 comments

  • cPRex Jurassic Moderator

    Hey there!  I'm not familiar with this script, and it's not something that is provided by cPanel, so I can't say for sure what the issue may be.  You'll likely need to examine the script, find the connection string, and adjust that.  I'm unsure why a script that is basically performing a local mysql dump and then a mv on the file would need an SSL connection, but I can't say for sure.

    1
  • MilesWeb

    Hello WorkinOnIt

    You need to check whether SSL is properly configured and the status is enabled in your MySQL server, If you have root access, you can check the path: /etc/my.cnf or /etc/mysql/my.cnf and look out for the SSL status.
    Additionally, you can verify whether the MySQL user has the necessary privileges or not.
    Hope this might help!

    0
  • WorkinOnIt

    Thanks for your replies.

    I fixed it by adding the following:  

    https://github.com/belgotux/automysqlbackup

    CONFIG_mysql_no_tablespaces='no'
    CONFIG_mysql_column_statistics='no'

    0

Please sign in to leave a comment.