Skip to main content
cPanel Technical Support has been heavily impacted by hurricane Beryl and our ability to respond to tickets has been hindered as a result. We appreciate your understanding and patience as we address these delays.

system update could not connect to server



  • Andrew


    Andrew N. - cPanel Plesk VMWare Certified Professional
    Do you need immediate assistance? 20 minutes response time!*
    EmergencySupport - Professional Server Management and One-time Services

  • rbairwell

    If you cannot connect to your server via WHM or SSH, then you need to contact your hosting provider/datacentre as there is nothing cPanel Inc can do to assist (as, even if you purchased a direct licence and therefore had "support entitlement", they wouldn't be able to connect to your server to help).

    I suspect it's probably just sitting on the BIOS "Select operating system" screen for some reason - but your hosting provider should be able to access the server either physically or via a remote access system such as DRAC or via (if applicable) the host server's virtual machine management system - some providers offer access to this via VNC or a "remote administrative shell/console" option. Again, if you go through your hosting provider, they should be able to help.

  • Colin Wood


    Thank you for your reply.

    I think at some point I stopped using firewalld and uninstalled it as I started using CSF, which is no longer installed either.

    In a recent update on Friday night to update the kernel and update some binary files, I restarted the server at which point I lost connection to the server. 

    I have Heart Internet provider and on an unmanaged server (basically it is GO-Daddy) 

    I raised ticket with my provider and this is their reply:

    Thanks for contacting us.
    Apparently, Your server is up and running. But it seems like the update you have done has blocked port 2224 which is responsible for My Hosting dashboard operation hence you're seeing the message "Server Dashboard Capability Is Limited" and your cPanel access button is grey. For smooth operation of your Generation 4 VPS or Dedicated Server, port 2224 is open by default when a server is provisioned. If server events don't complete because port 2224 gets blocked, unblock the port and try again after 15 minutes.
    For Linux servers, follow the steps below to use firewallD to unblock ports on the server. You may need to change this sample code if you're using a different firewall utility.
    Run this command:
    sudo firewall-cmd --permanent --zone=public --add-port=2224/tcp

    Run these commands:
    sudo firewall-cmd --reload
    sudo firewall-cmd --list-ports

    The second of these two commands verifies that the port is unblocked.

    I did what they said and unblocked the port but still was not able to access the server.

    Further I tried to install from an automatic backup just before the issue arose, but still no luck. I then installed a backup that I had ran from the 2nd December and I was able to connect and everything was working again.

    Is it a possibility that the update on Friday reinstalled the firewalld? The back up from the 2nd Dec did not have firewalld installed.

    Thanks in advance




  • cPRex Jurassic Moderator

    It's impossible for us to say what may have happened in this case, but it would be best to continue working with your provider to ensure it doesn't happen again.

    You could always try running a "yum update" command and just press "N" when it asks if you want to continue with the update.  That would let you see the list of packages that will be installed without making any changes.

  • rbairwell

    Ah - HeartInternet.... I used to use them (mainly for domain regs) before HostEurope brought them and then GoDaddy brought HostEurope.... The original founders setup (very very local to me) who I've found have been pretty good for the last 2 years (since I moved from Memset after 10+years).

    Instead of going via the HeartInternet control panel, did you try accessing the VPS directly on https://<ip address>:2087 , http://<ip address>:2086 or SSHing to port 22 (all bypassing the HeartInternet "My Hosting dashboard" port 2224 check)? It's possible that since port 2224 isn't a "default cPanel port", it could get automatically "blocked by default" by firewalld, CSF etc if for any reason they got updated.

    [grrr...What sort of VPS recovery console system requires an additional port to be unblocked on the server to work correctly? The idea of a recovery console is to be able to access the server if it is completely "offline" network wise. Memset, 20i and even *shudder* iomart provide console access "out of band" to handle situations like this]

  • Colin Wood


    I have been with Heart internet for 15 years, they used to be good but not anymore. Since GoDaddy took them over they have not solved one single issue in the past years it took them over 12 hours to send a reply with the server being down for the whole period. The last time I contacted support for assistance over than this issue it took them 4 days to reply! 

    In response to you questions, I never access the vps through Heart interface but could not connect to the server by https://<ip address>:2087 , http://<ip address>:2086 or SSHing to port 22.

    The only way was through QEMU - no vnc. Which is how I added the port 2224 but the server was still down.

    I know I need to move to someone else so I will give a call today.

    I am currently running centros 7 and I need to upgrade to Alamalinux which I have tried to upgrade using elevate but did not get the upgrade menu and lost access to the server and when I went to recovery console the menu options appeared but when I tried to access it would not let me it says  
    Shell access is not enabled on your account contact your system administrator. 

    Its all been a bit of a nightmare as I can only make changes on weekends due to my partners business relying on the services up and running. 


  • Colin Wood


    Been messing around with Firewalld which I disabled to access the server over the weekend. Today I enabled firewalld and lost all access to the server again. 

    I assume that the issue is there are no rules in the firewalld which is why I am losing the connection. 

    Disabled firewalld from Quemu and eventually regained the connection. 

    Should I remove the firewalld completely and reinstall and get back the default open ports?

    Thanks in Advance.


  • cPRex Jurassic Moderator

    That may be the simplest option, yes.  Details on what we need for things to work can be found here:


  • Colin Wood


Please sign in to leave a comment.