Skip to main content

PHP 8.2 Install Issue / Conflict

Comments

16 comments

  • cPRex Jurassic Moderator

    Hey there!  What is the output of the following command on your server?

    rpm -qa | grep -i argon

    Once we know that we can move to the next steps to get this working.

    0
  • tommyxv

    Hello,

    here you go...

    [root@server ~]# rpm -qa | grep -i argon
    ea-libargon2-20161029-3.el8.cloudlinux.2.x86_64

    My OS is AlmaLinux v8.9.0 STANDARD standard if that matters.

    Thanks

    0
  • cPRex Jurassic Moderator

    That's likely the issue then.  Remove the package with this command:

    rpm -e --nodeps ea-libargon2

    and then try your work again and it should work well.

    1
  • tommyxv

    If I do that, will it affect my current PHP 8.1 install? I have sites using 8.1 that I will be moving to 8.2.

    0
  • cPRex Jurassic Moderator

    No, this package is not specific to PHP, and it's already causing problems.  There may be a quick hiccup while the new packages are installed and PHP is reloaded, so if you wanted to wait until non-peak hours for the users, being cautious is never a bad plan.

    1
  • tommyxv

    Sounds good. Thank you for the help!

    1
  • cPRex Jurassic Moderator

    You're very welcome!  Let me know if that doesn't take care of the issue!

    0
  • tommyxv

    Worked perfectly!  I assume it is safe to remove 8.0 and 8.1 now? Everything has been moved to 8.2. 

    0
  • cPRex Jurassic Moderator

    I'm glad to hear that worked well!  Yes, if all of your accounts are now on PHP 8.2 you can remove the older versions and that will not cause any conflicts.

    0
  • tommyxv

    Great, thanks! 

    0
  • ThatHostingCo

    I had this same issue and ran the fix. Resolved the issue and now I am getting the following in Almalinux 8.9:

     Problem 1: package ea-php83-php-intl-8.3.2-1.1.1.cpanel.x86_64 from EA4 requires libicudata.so.69()(64bit), but none of the providers can be installed
      - package ea-php83-php-intl-8.3.2-1.1.1.cpanel.x86_64 from EA4 requires libicui18n.so.69()(64bit), but none of the providers can be installed
      - package ea-php83-php-intl-8.3.2-1.1.1.cpanel.x86_64 from EA4 requires libicuuc.so.69()(64bit), but none of the providers can be installed
      - package ea-php83-php-intl-8.3.2-1.1.1.cpanel.x86_64 from EA4 requires libicuio.so.69()(64bit), but none of the providers can be installed
      - cannot install both ea-libicu-69.1-1.1.61.cpanel.x86_64 from EA4 and ea-libicu-1:69.1-1.el8.cloudlinux.x86_64 from @System
      - cannot install both ea-libicu-69.1-1.1.62.cpanel.x86_64 from EA4 and ea-libicu-1:69.1-1.el8.cloudlinux.x86_64 from @System
      - cannot install both ea-libicu-69.1-2.2.16.cpanel.x86_64 from EA4 and ea-libicu-1:69.1-1.el8.cloudlinux.x86_64 from @System
      - cannot install both ea-libicu-69.1-2.2.17.cpanel.x86_64 from EA4 and ea-libicu-1:69.1-1.el8.cloudlinux.x86_64 from @System
      - cannot install the best candidate for the job
     Problem 2: package ea-php82-php-intl-8.2.15-1.2.1.cpanel.x86_64 from EA4 requires libicudata.so.69()(64bit), but none of the providers can be installed
      - package ea-php82-php-intl-8.2.15-1.2.1.cpanel.x86_64 from EA4 requires libicui18n.so.69()(64bit), but none of the providers can be installed
      - package ea-php82-php-intl-8.2.15-1.2.1.cpanel.x86_64 from EA4 requires libicuuc.so.69()(64bit), but none of the providers can be installed
      - package ea-php82-php-intl-8.2.15-1.2.1.cpanel.x86_64 from EA4 requires libicuio.so.69()(64bit), but none of the providers can be installed
      - cannot install both ea-libicu-69.1-1.1.61.cpanel.x86_64 from EA4 and ea-libicu-1:69.1-1.el8.cloudlinux.x86_64 from @System
      - cannot install both ea-libicu-69.1-1.1.62.cpanel.x86_64 from EA4 and ea-libicu-1:69.1-1.el8.cloudlinux.x86_64 from @System
      - cannot install both ea-libicu-69.1-2.2.16.cpanel.x86_64 from EA4 and ea-libicu-1:69.1-1.el8.cloudlinux.x86_64 from @System
      - cannot install both ea-libicu-69.1-2.2.17.cpanel.x86_64 from EA4 and ea-libicu-1:69.1-1.el8.cloudlinux.x86_64 from @System
      - package ea-php74-php-intl-1:7.4.33-2.el8.cloudlinux.1.x86_64 from @System requires ea-libicu >= 1:69, but none of the providers can be installed
      - cannot install the best candidate for the job

    Any ideas?

    0
  • cPRex Jurassic Moderator

    ThatHostingCo - are you running CloudLinux on that machine?  If not, you'll want to remove or disable the CloudLinux repositories to avoid this conflict.

    0
  • ThatHostingCo

    I'm running the Imunify360 Hardened packages.

    0
  • ThatHostingCo

    To note, it ran the install just fine on my other server running the same setup. The only difference is that this is running in a VPS as opposed to a dedicated server.

    0
  • cPRex Jurassic Moderator

    The recommended way to handle those conflicts is with the details here:

    https://cloudlinux.zendesk.com/hc/en-us/articles/4410705671314-Imunify360-packages-are-not-updated-due-to-conflicts

    1
  • ThatHostingCo

    Actually, I found this article just off that one that worked better to the issue: https://cloudlinux.zendesk.com/hc/en-us/articles/4408411384722-Yum-cannot-install-the-best-update-candidate-for-package-on-server-with-Imunify360

    Seems this issue occurred before with the PHP 7.4 Release.

    1

Please sign in to leave a comment.