Skip to main content

Unable to login in WHM

Comments

11 comments

  • quietFinn

    How do you try to connect?
    http://your.hostname:2087
    http://your.hostname/whm
    http://<server-IP>:2087
    http://<server-IP>/whm

    0
  • Unnamed User

    I tried with

    <server-IP>/whm and <domain>/whm , they both redirect to :2087
    I even tried the hosting company link provided years ago when creating the account

    all https:// because http redirects to hosting company link, that also does not work

    It used to be working just fine from <domain>/whm , i used it daily for years, just recently after i messed with the login by google on an OTHER whm setup, its doing this. I am not sure if its pure coincidence or this is somehow related

    From other pc works fine, but this is my main work pc and i really need it to work on this one.. :(

     

     

    0
  • rbairwell

    Since you are able to login to the server via another way, can you go to Security Center->Configure Security Policies and see if "Limit logins to verified IP Addresses" is ticked or not? And if you have any security questions/recognised IP addresses setup in Security Center->Security Questions. If I remember correctly, these tend to be the issue when "'A network error occurred during your login request. Please try again. If this condition persists, contact your network service provider." ONCE you have ruled out cookies/changing IP addresses being an issue.

    Have you got "Two-Factor Authentication" enabled? And are you going directly to https://<server>:2087/ and ensuring that you do not have a "cpsess..." line stored?

     

    1
  • Unnamed User

    i checked now, and there is nothing ticked on the SecurityPolicies page, also no security questions or anything set in recognized ip section

    Also i do not have 2FA enabled

    Yes i am going directly to :2087, no cpsess line 

     

    .. feeling desperate.. Thanks a lor for your support

    0
  • cPRex Jurassic Moderator

    If going directly to x.x.x.x:2087 using the IP is still giving you this issue, you'll need to speak with your hosting provider or datacenter to have them do some additional troubleshooting with you.

    0
  • Unnamed User

    Hosting checked, its working for them, so on their end they say its no problem, and i tend to believe them.

    I noticed i have exactly same issue on other whm on completely different machine. I checked multiple browsers, multiple IPs and the ONLY thing that i can see in common is the physical machine that i am on (work computer)

    Basically right now the only whm access that works for me is on the machine where i setup login by google, no other whm works anymore.

    I am afraid to disable google on that one because if i lose access to that one too it will be even more dramatic.

     

    0
  • Unnamed User

    I risked disabling login by google in whm, and I can confirm that now i can not login in any whm's on this machine, regardless of ip, hosting provider, or browser. I even installed a new browser to be sure.

    Windows 11 Pro 10.0.22631

    NUC-i7-GEN12

    Same situation with cpanel, same error

    Time on the machine is auto synced. 

    I noticed this error in console:
    POST https://realmente.ro:2083/login/?login_only=1 net::ERR_EMPTY_RESPONSE
    AjaxObject.update @ (index):269
    do_login @ (index):269

     

    I see the same on other browsers and other websites where i try to login via cpanel or whm

    This is unreal... :(

     

     

    0
  • cPRex Jurassic Moderator

    It has to be something local to your network if all cPanel services aren't working from that location.  What if you try tethering to your phone or a different network as a test?

    0
  • rbairwell

    For emergency WHM access, login via root SSH and run:

    /scripts/whmlogin

    - it will produce a single use URL such as:

    https://server.example.com:2087/cpsessxxxxxxx/login/?session=root%3axxxxxx%3acreate_user_session%2cxxxxxxx

    which give you WHM access.

    It's odd that if you are trying to log into WHM on port 2087, it would make any calls to port 2083 - the only thing I can think of that could cause this (and hence be the route of your problems) would be a misconfigured corporate firewall/proxy server.

    [added]

    I'm still trying to replicate/find the cause of the error myself (baring in mind, I'm just another customer and not a member of cPanel staff), but based on an old forum comment by myself (which has been a bit corrupted in the forum migration - any chance cPRex can fix https://support.cpanel.net/hc/en-us/community/posts/19163197801751-WHM-Login-failure-A-network-error-occurred-during-your-login-request ? ), it *might* be (based on the fact you are using a corporate network) your initial page request and then the login submission are reaching the server from different IP addresses as the corporate network may route the request different. This is then triggering the "Cookie IP validation" security filter in "Tweak Settings" (I'm guessing it's currently set to "strict (default)"). Try changing that to "loose" or "disabled" to see if that helps.

    (Another thing that could be causing it is the "Blank referrer safety check" and "Referrer safety check" - again under the "Security" section of WHM's "Tweak settings": you could try toggling those and see if it makes any difference). Something on the corporate network is causing problems and, at least for my personal curiosity, I'd love to find out what it is.!

    0
  • Unnamed User

    OMG thats so useful all of it. Thanks for all the info!

    I managed to get it working, but i am still confused about what caused this issue that tortured me so long. I disabled the antivirus (Bitdefender), but apparently it has this "feature" called "web attack prevention" ..that was not disabled and i had to find some obscure checkbox in its horrible interface. 

    After disabling it , it did not work, but later on when i restarted the pc, now i can login to WHM!! ..

    i have no ideea if it will work again on next restart, because now i enabled that checkbox back and it still works.. Anyway i am not shutting down pc anymore, it can stay on as long as i can work on it without needing my phone to login to whm :))

     

     

    0
  • rbairwell

    Okay, tracking through the code the text "A network error occurred during your login request. Please try again. If this condition persists, contact your network service provider." is actually contained within /usr/local/cpanel/Cpanel/Template/Unauthenticated.pm which is sent as MESSAGES.network_error to /usr/local/cpanel/base/unprotected/cpanel/js/login.js which is displayed when a login attempt is made, but the status code is NOT 200 or 4xx.

    I would guess, based on that (and if I'm reading the code correctly at 3am), you are probably getting a HTTP Response code of 3xx or 5xx when you submit the details. If you can have the web browser developer toolbar open when you submit and look out for a failed request with a matching error code and let us know what code it is and what, if anything appears in the "Response" section it could be helpful.

    I now have a suspicion that you'll see a response from your corporate firewall (possible Fortigate) saying something along the lines of "Request Blocked: Reason - Security. HTTP.Post requests with parameter root are blocked"). If I'm correct, you'll need to contact your network administrator to ask them to make a custom firewall rule for you to use the "root" user to login to the servers (if you provide the hostnames/IP addresses of the server and ask nicely giving justification as to why you need to login to those servers at work - they should be able to tweak the corporate firewall security policy to accommodate it).

    1

Please sign in to leave a comment.