Skip to main content

WP Toolkit is not working, getting Error: Initial data load error: some required fields are not provided

Comments

11 comments

  • cPRex Jurassic Moderator

    Hey there!  If your hosting provider isn't able to solve a problem, they should have escalated the ticket to us instead of sending you out on your onw.

    In this case, I would try reinstalling the WP Toolkit package with the following command:

    yum reinstall wp-toolkit-cpanel

    Can you try that and see if that gets things working?

    0
  • Dan Weber

    Reinstalled:
      wp-toolkit-cpanel-6.2.13-7808.x86_64

    Still not working, below is the console log

     

    whm-wp-toolkit-api registered
    Perform initial settings
    /usr/bin/sw-engine: error while loading shared libraries: /lib64/libodbc.so.2: file too short
    Install services
    enabled
    enabled
    Fetch leika config
    /usr/bin/sw-engine: error while loading shared libraries: /lib64/libodbc.so.2: file too short
    ---
    metadata:
      command: set_tweaksetting
      reason: OK
      result: 1
      version: 1
    1
  • Dan Weber

    I was able to fix this. I found the problem, 

    Getting error :

    usr/bin/sw-engine: error while loading shared libraries: /lib64/libodbc.so.2: file too short

    pasted that on Chat GPT, it gave few commands to solve the issue and and I again reinstalled WP toolkit.. It is now working.

    Thank you cPanel support team & ChatGPT

    0
  • cPRex Jurassic Moderator

    It would be great if you could share the commands you ended up running here.

    0
  • Dan Weber
    yum update
    ls -l /lib64/libltdl.so.7
    rpm -qf /lib64/libltdl.so.7
    yum reinstall libtool-ltdl
    yum reinstall wp-toolkit-cpanel
    1
  • cPRex Jurassic Moderator

    The first three commands wouldn't have done anything to resolve the issue, but I'm glad the last two helped!

    0
  • inforex
    AlmaLinux v8.9.0 STANDARD standard
    cPanel Version
    116.0.13
     
    I have the same error but these commands didn't help me, any other solution?
    0
  • inforex

    Perform initial settings
    /usr/bin/sw-engine: error while loading shared libraries: /lib64/libodbc.so.2: file too short
    Install services
    enabled
    enabled
    Fetch leika config
    /usr/bin/sw-engine: error while loading shared libraries: /lib64/libodbc.so.2: file too short
    ---
    metadata:
      command: set_tweaksetting
      reason: OK
      result: 1
      version: 1

    /sbin/ldconfig: File /lib64/libesoobS.so.2 is empty, not checked.

    ...

    /sbin/ldconfig: File /lib64/libtemplate.so.2.0.0 is empty, not checked.

      Verifying        : wp-toolkit-cpanel-6.2.13-7808.x86_64                                                                                                                 1/2
      Verifying        : wp-toolkit-cpanel-6.2.13-7808.x86_64                                                                                                                 2/2

    Reinstalled:
      wp-toolkit-cpanel-6.2.13-7808.x86_64

    Complete!

    0
  • cPRex Jurassic Moderator

    inforex - are things working well for you now?

    0
  • inforex

    No, I still have the error and I can't find a solution.
    thank you.

    0
  • cPRex Jurassic Moderator

    It would likely be best to submit a ticket if the above fixes aren't working properly on your system.

    0

Please sign in to leave a comment.