Skip to main content

DEF-27492 - Error Check Email

Comments

15 comments

  • cPRex Jurassic Moderator

    Hey there!  Do you see any additional errors in the /usr/local/cpanel/logs/error_log file?  If not, I'd try running "/scripts/upcp --force" to see if that takes care of things.

    0
  • Unnamed User

    Hello.

    Thank you for your comment.

    - It doesn't solve it, we already did it twice (/scripts/upcp --force)

    - /usr/local/cpanel/logs/error_log file:

    [2024-03-21 03:50:34 -0400] warn [cpanel] Failed to load module “Styles”: Cpanel::Exception::ModuleLoadError/(XID v7hy3a) The system failed to load the module “Cpanel::API::Styles” because of an error: Can't locate Cpanel/API/Styles.pm in @INC (you may need to install the Cpanel::API::Styles module) (@INC contains: /usr/local/cpanel /usr/local/cpanel/3rdparty/perl/536/cpanel-lib/x86_64-linux /usr/local/cpanel/3rdparty/perl/536/cpanel-lib /usr/local/cpanel/3rdparty/perl/536/lib/x86_64-linux /usr/local/cpanel/3rdparty/perl/536/lib /opt/cpanel/perl5/536/site_lib/x86_64-linux /opt/cpanel/perl5/536/site_lib) at (eval 7) line 1, <$inputfd> line 5.
    BEGIN failed--compilation aborted at (eval 7) line 1, <$inputfd> line 5.

     at /usr/local/cpanel/Cpanel/LoadModule.pm line 77, <$inputfd> line 5.
            Cpanel::LoadModule::load_perl_module("Cpanel::API::Styles") called at /usr/local/cpanel/Cpanel/API.pm line 327
            eval {...} called at /usr/local/cpanel/Cpanel/API.pm line 327
            Cpanel::API::_init_execute("Styles", "list") called at /usr/local/cpanel/Cpanel/API.pm line 170
            Cpanel::API::execute("Styles", "list", undef) called at cpanel.pl line 1341
            cpanel::cpanel::docpanelaction("<cpanelaction>\x{a}{\"module\":\"Styles\",\"reqtype\":\"exec\",\"func\":\"li"...) called at /usr/local/cpanel/Cpanel/Parser/Legacy.pm line 240
            Cpanel::Parser::Legacy::_dotag_finished_headers(0) called at /usr/local/cpanel/Cpanel/Parser/Legacy.pm line 79
            Cpanel::Parser::Legacy::cpanel_parseblock("<cpanelaction>\x{a}{\"module\":\"Styles\",\"reqtype\":\"exec\",\"func\":\"li"...) called at /usr/local/cpanel/Cpanel/Parser/Legacy.pm line 368
            Cpanel::Parser::Legacy::parse(GLOB(0x28bb5d0), 1) called at cpanel.pl line 4634
            cpanel::cpanel::run_standard_mode() called at cpanel.pl line 928
            cpanel::cpanel::script("cpanel::cpanel", "./3rdparty/sitepad/index.live.php") called at cpanel.pl line 324

    [2024-03-21 03:50:40 -0400] die [Internal Death while parsing ./frontend/jupiter/mail/webmailform.html.tt 2347] Template::Exception:

    0
  • cPRex Jurassic Moderator

    Thanks for the additional details.  Do you have any third-party plugins installed on the server that could be causing this conflict?

    If not, can you run the following commands on the server to see if that resolves the issue?

    mv /usr/local/cpanel/base/frontend/jupiter /usr/local/cpanel/base/frontend/jupiter.bak
    /scripts/upcp --force

    Let me know if that gets things working!

    0
  • Unnamed User

    These are the installed plugins that are on all our servers:

    • CageFS
    • CloudLinux Manager
    • ConfigServer Mail Manage
    • ConfigServer Mail Queues
    • ConfigServer ModSec Control
    • ConfigServer Security & Firewall
    • JetBackup 5
    • LiteSpeed Web Server
    • SitePad Website Builder
    • Softaculous - Instant Installs
    • WP Toolkit

    If what you tell us is executed, will it affect any of them?

    0
  • cPRex Jurassic Moderator

    No, that area of the system is exclusively managed by cPanel so I wouldn't expect that to cause harm to any plugins.

    0
  • Team WIPL

    Hi cPRex

    We too are facing this issue.

    I have additionally noticed few more things:
    1. These have affected only Server with CloudLinux 8
    2. Updates are also affected:

    Error:
     Problem: package postfix-perl-scripts-2:3.5.8-7.el8.x86_64 requires postfix = 2:3.5.8-7.el8, but none of the providers can be installed
      - installed package cpanel-exim-4.96.2-2.cp108~el8.x86_64 obsoletes postfix provided by postfix-2:3.5.8-7.el8.x86_64
      - cannot install the best update candidate for package postfix-perl-scripts-2:3.5.8-4.el8.x86_64
      - problem with installed package cpanel-exim-4.96.2-2.cp108~el8.x86_64
    (try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages).

    3. The issue is not related to the Nginx as it was stated in the earlier case:
    - https://support.cpanel.net/hc/en-us/articles/6558703229719-Webmail-gives-fatal-error-with-ea-nginx-in-use-Over-standard-port-expect-cpanel-service-subdomain
    I have tested this by removing the Nginx from server, yet the issue remains.

    0
  • Wiz

    Occurring on a server with CentOS 7, CloudLinux, Imunify360 and without Nginx.

    0
  • cPRex Jurassic Moderator

    I wouldn't expect Nginx to be related to the webmail processes at all.

    Could one of you experiencing the issue please submit a ticket so we can check this out?

    0
  • Unnamed User

    The problem with tickets to Cpanel is now what the Cpanel license provider must do. In my case it is OVH and they say they have nothing to do with that.

    0
  • cPRex Jurassic Moderator

    Wiz - would you be able to submit a ticket?

    0
  • cPRex Jurassic Moderator

    Update - it looks like this may be related to Imunify:

    https://support.cpanel.net/hc/en-us/articles/22086701147799-Webmail-Error-Template-Exception?

    Can you try the details there and see if that gets things working?

    0
  • Unnamed User

    I disabled protection and it worked. We hope then that imunify360 resolves it in a future update.

    Thank you

    0
  • cPRex Jurassic Moderator

    Excellent news - I'm glad that's working well now!

    0
  • Wiz

    works for me too, thanks!

    0
  • cPRex Jurassic Moderator

    Glad to hear it!

    0

Please sign in to leave a comment.