Skip to main content

Address Book Import Fails




  • cPRex Jurassic Moderator

    Hey there!  It seems like the operation timed out or hit a limit of some sort.  I would check the main cPanel error log (/usr/local/cpanel/logs/error_log) or the Roundcube logs ( to see if any of those provide more details on what may have went wrong with the operation.

  • kedarbhise

    Thanks cPRex for pointing towards the log files.

    The CSV file has only 34 entries. Timeout is most likely not an issue.

    I found the issue in the file carddav.log found at


    The Notes field for one of the entries caused an error as below

    <38ccb34d> [5 ERR] save data notes must be stringArray

    Tried removing that, but encountered more errors such as:

    PHP Fatal error:  Uncaught TypeError: strlen(): Argument #1 ($string) must be of type string, array given in /usr/local/cpanel/base/3rdparty/roundcube/plugins/carddav/src/DataConversion.php:576

    Gave up and ended up importing the .vcf file. That worked correctly.

    Likely Root Cause:

    I had converted the vcf to csv using an online tool to allow merging with other csv files and remove duplicate entries. Most likely, the online tool introduced some characters in the Notes fields that caused the import code to break.

    Thanks for your support.

  • cPRex Jurassic Moderator

    Interesting, but I'm glad that got you pointed in the right direction!


Please sign in to leave a comment.