Skip to main content

Roundcube Not Loading

Comments

16 comments

  • Lionel Whitecross

    we are having the same issue on all our user accounts using roundcube from the latest update.

    Worked fine until update

    1
  • JMAK

    Good to know, I'm not the only one! 

    If i come across any fix, ill note here. 

    0
  • cPRex Jurassic Moderator

    There are several threads about the issue after the latest update.  The specific issue being described here is this problem:

    https://support.cpanel.net/hc/en-us/articles/23054515351959-After-upgrading-to-cPanel-120-webmail-proxy-subdomain-will-not-load-when-behind-Cloudflare

    Let me know if that helps!  We should have a workaround for this soon.

    0
  • JMAK

    We do use Cloudflare, but DNS Proxy was already off:

    No change was made to our setup prior to this issue other than updating to 120.0.2

    Thanks

    0
  • Lionel Whitecross

    fixed my issue

    0
  • JMAK

    Thanks for sharing Lionel.

    I believe these two issues are potentially different.

    We have continued with our testing and we do have a workaround however is not ideal.

    If our users login via webmail.XXX.co.uk, they will face the issue we have detailed above, however if they login via cprapid.com domain, on port 2096*, everything works as expected. 

    *https://XXX-XXX-XXX-XXX.cprapid.com:2096/

    This seems to highlight that issue we are experiencing and reporting is potentially different to what has been reported and discussed so far.

     

    0
  • cPRex Jurassic Moderator

    Yes, the Cloudflare issue is different from the other issues Lionel reported.  There are two separate issues with that Roundcube update and we are addressing both.

    0
  • JMAK

    Thanks cPRex.

    Just adding few additional screenshot here if other users are having similar issues;

    With cloudflare proxy on webmail A record, end user will see the following after clicking on Roundcube:

    With cloudflare proxy off webmail A record, our users see:

    The only workaround for us is to use the cprapid.com domain, on port 2096*:

    *https://XXX-XXX-XXX-XXX.cprapid.com:2096/

    0
  • fevangelou

    I can confirm the issue is related to how cPanel bootstraps Roundcube, when called via a subdomain.

    By adding breakpoints in the entry file for Roundcube in "/usr/local/cpanel/base/3rdparty/roundcube/index.php", I noticed that the error occurs after the call to:

            // send auth cookie if necessary
            $RCMAIL->session->set_auth_cookie();

    (in around lines 128-129) if it helps.

    Since this API is Roundcube specific I didn't dig further, but I can verify it's not related to any proxy, CloudFlare etc. but exclusive to Roundcube, or at least how Roundcube is integrated into cPanel.

    1
  • Global Hosting BiH

    Hi, this fixed our issue, hope it helps. This only fixed the problem when cloudflare proxy was turned off and DNS only was set.

    iptables -t nat -A OUTPUT -d $PUBLIC-IP -p tcp -m tcp --dport 2080 -j DNAT --to-destination $INTERNAL-IP:2080



    https://support.cpanel.net/hc/en-us/articles/23010721161751-Roundcube-is-not-accessible-with-502-error

    1
  • JMAK

    Thats amazing, our workaround is doing the job for now, but we will review and attempt this over the weekend :)

    Many Thanks 

    0
  • Marvin Huijbregts

    Also solved the problem for me Global Hosting BiH

    This workaround does not come with any security complications ?

     

    0
  • cPRex Jurassic Moderator

    No, that is safe to run.

    0
  • by_error

    Source github  Cloudflare 524 Error with Roudcube #9436

    Solution:
    Replace the following code in the /usr/local/cpanel/base/3rdparty/roundcube/plugins/carddav/config.inc.php file, and the webmail will work:

     

    <?php
    $prefs['_GLOBAL']['suppress_version_warning'] = false;
    $prefs['_GLOBAL']['sync_collection_workaround'] = false;
    if(file_exists('/var/cpanel/calendarserver')) {
    $domain = getenv('HTTP_HOST');
    if( empty($domain) ) $domain = getenv('DOMAIN');
    // Figure out the expected formatting based on username 
    $userName = (string) $_SERVER['_RCUBE'];
    $userFormat = (string) '%l@%d'; 
    if( strpos($userName, '/') === false) { 
    $userFormat = '%l'; 
    }
     
    $prefs['cPCardDAV'] = array( 
       'name'     => 'cPanel CardDAV', 
       'username' => $userFormat, 
       'password' => '%p', 
       'url'      => 'https://' . $domain . ':2080/addressbooks/' . $userFormat . '/addressbook/', 
       'active'   => true, 
       'fixed'    => array( 'name', 'username', 'password' ), 
       'hide'     => false, 
    );
    }
     
    ?>

     

    0
  • cPRex Jurassic Moderator

    by_error - remember, any config files owned by cPanel will be overwritten on the next update if they have customizations.

    0

Please sign in to leave a comment.