Skip to main content
cPanel Technical Support has been heavily impacted by hurricane Beryl and our ability to respond to tickets has been hindered as a result. We appreciate your understanding and patience as we address these delays.

New Configuration Causing Problems

Comments

14 comments

  • cPRex Jurassic Moderator

    Hey there!  When this issue happens, what shows up in the Apache log (/etc/apache2/logs/error_log) on the server?  I would expect there to be more details there.

    0
  • Andrew Kirwin

    This was a good lead, but it raises more questions. What the log is showing is "[client 72.197.212.225:0] client denied by server configuration". And 72.197.212.225 is my office IP address. The problem is that I have (and had) my office IP address whitelisted in CSF and cPHulk. As someone who only understands about 10% of the server-side, I am wondering if having both CSF and cPHulk is a problem? Or is there another place I need to whitelist my IP address?

    0
  • cPRex Jurassic Moderator

    It could be an issue as they can both perform similar functions.  If you disable cPHulk are you able to access the pages normally?

    0
  • Andrew Kirwin

    Unfortunately, that doesn't seem to have fixed it. Disabled cPHulk, began two admin sessions, within minutes, got a 404 in the second site. This is the error log:

    <redacted

    0
  • cPRex Jurassic Moderator

    Thanks for the additional details.  This is an issue with ModSecurity on the system - can you try the adjustment mentioned here?

    https://support.cpanel.net/hc/en-us/articles/360052471154-How-to-fix-Failed-to-access-DBM-file

    0
  • cPRex Jurassic Moderator

    I also redacted that log as we can't share domain names or IPs on the Forum.

    0
  • Andrew Kirwin

    Thank you. I was just in a rush, I appreciate that very much. Am doing a restart on server now, will let you know if it worked.

    0
  • cPRex Jurassic Moderator

    Sounds good!

    0
  • Andrew Kirwin

    I am getting this recommendation in EasyApache:

    PHP DSO runs as the user nobody by default. In a shared hosting environment, this is a security issue.

    • We strongly recommend that you install one of the following packages unless this is a single-user system:
      • ea-apache24-mod_ruid2
      • ea-apache24-mod_mpm_itk
    • If you use suPHP, you will add some security, but may experience performance issues on your server.
    0
  • Andrew Kirwin

    No joy, still getting a 404 randomly

     

    0
  • cPRex Jurassic Moderator

    Did the entries in the Apache logs change after that work?

    0
  • Andrew Kirwin

    No, still getting  "[client 72.197.212.225:0] client denied by server configuration".

    0
  • cPRex Jurassic Moderator

    Can you create a support ticket so the server can be examined?

    0
  • Andrew Kirwin

    Yes. The cPanel license is under my server provider - even though it's a dedicated server. I have asked them to help me do this.

    1

Please sign in to leave a comment.