Skip to main content

Errors during downloading metadata for repository 'MariaDB106'

Comments

14 comments

  • mtindor

    Looks like they may have updated the archive on Aug 13th.

    https://archive.mariadb.org/mariadb-10.6/yum/

    No more CentOS 8 in that archive

    Keep in mind that MariaDB 10.6 reached EOL in July 2026

    0
  • marjwyatt

    mtindor I am not using CentOS8.  My VPS is running Alma Linux.

    I knew there were yum files in that folder.  I didn't look at the date.

    Are you saying I need to update MariaDB to get the update to work?

    0
  • mtindor

    I didn't say you were running CentOS 8, but your repo baseurl was linking to a centos/8/x86_64 folder.   That no longer exists.

    Looks like they may have what you need in  the /mariadb-10.6/yum/almalinux8-x86_64 folder.

    However, I am NOT telling you to use that.  You should do some further investigation and ask questions of cPanel / Almalinux about what repo you should be using now, since the MariaDB folks moved things around.

     

     

    0
  • cPRex Jurassic Moderator

    Someone else posted a similar experience here, so it seems that is fine to use: https://support.cpanel.net/hc/en-us/community/posts/42227828850199

    0
  • marjwyatt

    cPRex I upgraded to MariaDB 11.4 yesterday.  The upgrade created a new MariaDB114.repo file.  Here are the contents of that file:

    [MariaDB114]
    name = MariaDB114
    baseurl = https://archive.mariadb.org/mariadb-11.4/yum/centos/8/x86_64
    gpgkey=https://archive.mariadb.org/PublicKey
           https://supplychain.mariadb.com/MariaDB-Server-GPG-KEY
    gpgcheck=1

    My concern is that the baseurl can't be reached using a browser.  This was the same issue that caused the last cPanel updates to fail with one error last week.  So, is that the correct baseurl to use in this file?

    I ran some other commands to help you understand my VPS server environment.

    MariaDB

    [root@server1 ~]# yum whatprovides MariaDB-server
    Last metadata expiration check: 1:17:18 ago on Mon 17 Aug 2026 10:14:55 AM PDT.
    MariaDB-server-11.4.10-1.el8.x86_64 : MariaDB database server binaries
    Repo        : MariaDB114
    Matched from:
    Provide    : MariaDB-server = 11.4.10-1.el8

    MariaDB-server-11.4.11-1.el8.x86_64 : MariaDB database server binaries
    Repo        : MariaDB114
    Matched from:
    Provide    : MariaDB-server = 11.4.11-1.el8

    MariaDB-server-11.4.12-1.el8.x86_64 : MariaDB database server binaries
    Repo        : @System
    Matched from:
    Provide    : MariaDB-server = 11.4.12-1.el8

    MariaDB-server-11.4.12-1.el8.x86_64 : MariaDB database server binaries
    Repo        : MariaDB114
    Matched from:
    Provide    : MariaDB-server = 11.4.12-1.el8

    OS

    [root@server1 ~]# cat /etc/os-release
    NAME="AlmaLinux"
    VERSION="8.10 (Cerulean Leopard)"
    ID="almalinux"
    ID_LIKE="rhel centos fedora"
    VERSION_ID="8.10"
    PLATFORM_ID="platform:el8"
    PRETTY_NAME="AlmaLinux 8.10 (Cerulean Leopard)"
    ANSI_COLOR="0;34"
    LOGO="fedora-logo-icon"
    CPE_NAME="cpe:/o:almalinux:almalinux:8::baseos"
    HOME_URL="https://almalinux.org/"
    DOCUMENTATION_URL="https://wiki.almalinux.org/"
    BUG_REPORT_URL="https://bugs.almalinux.org/"

    ALMALINUX_MANTISBT_PROJECT="AlmaLinux-8"
    ALMALINUX_MANTISBT_PROJECT_VERSION="8.10"
    REDHAT_SUPPORT_PRODUCT="AlmaLinux"
    REDHAT_SUPPORT_PRODUCT_VERSION="8.10"
    SUPPORT_END=2029-06-01

    cPanel

    [root@server1 ~]# cat /usr/local/cpanel/version
    11.136.0.33

    I do hope to hear back from you.  Thanks, in advance, for your consideration.

    0
  • quietFinn

    If you were able to install MariaDB 11.4 the repo is fine, and if the repo was not good then running:
    yum update
    would throw an error.

    That baseurl works for me.

     

    0
  • marjwyatt

    quietFinn - Although I still cannot get to the baseurl via browser, your idea of running yum update worked.  So, ultimately, the misadventure onf a failed cPanel update led me to updating MariaDB and much more.  :)

    0
  • BassTeQ

    I'm experiencing the same issue, what is recommended fix?

    OS: AlmaLinux 8.10
    cPanel Version 136

    cat /etc/yum.repos.d/MariaDB106.repo
    [MariaDB106]
    name = MariaDB106
    baseurl = https://archive.mariadb.org/mariadb-10.6/yum/centos/8/x86_64
    gpgkey=https://archive.mariadb.org/PublicKey
           https://supplychain.mariadb.com/MariaDB-Server-GPG-KEY
    gpgcheck=1

    rpm -qa | grep -i '^MariaDB'
    MariaDB-client-10.6.27-1.el8.x86_64
    MariaDB-common-10.6.27-1.el8.x86_64
    MariaDB-server-10.6.27-1.el8.x86_64
    MariaDB-devel-10.6.27-1.el8.x86_64
    MariaDB-shared-10.6.27-1.el8.x86_64

    yum repolist all | grep -i MariaDB
    MariaDB106                     MariaDB106                               enabled
    0
  • Dan Thompson

    If you update the baseurl to the following:

    https://archive.mariadb.org/yum/10.6/centos/8/x86_64/

    Then run yum update again, it will fix the issue.

    Edited to say the above is the baseurl to use if you are on Alma/RHEL8. If you are still on 7 then the baseurl would be:

    https://archive.mariadb.org/yum/10.6/centos/7/x86_64/

    0
  • BassTeQ

    Thanks very much, this has resolved the issue.

    0
  • cPRex Jurassic Moderator

    Update - we've confirmed that MariaDB removed these on their end and have published an official article you can use to get this working again: https://support.cpanel.net/hc/en-us/articles/42919127133335-New-cPanel-installs-on-CloudLinux-AlmaLinux-8-failing-due-to-MariaDB-repo-changes

    0
  • marjwyatt

    cPRex It is wonderful to learn that cPanel has identified the root cause of the problem and supplied a workaround.  As you may have had time to notice, since opening this thread I have updated MariaDB via WHM and I also updated to Alma Linux 8.10.  Both updates ended without errors.

    On August 22, 2026, I received an email notification that the md5sum comparison test failed on CURL.  On August 23, 2026, I received an email notification that the md5sum comparison test had failed for multiple files related to MariaDB.  In my past experience, those types of notifications indicate that the updates succeeded, so I rebooted the server on both days.  I had no system integrity notifications in my inbox this morning.

    So, before I embark on the workaround recommended on the official cPanel article, how can I check to see it is broken and needs to be fixed?  

    0
  • cPRex Jurassic Moderator

    If it's broken you'd be getting nightly update failure notifications from the system.  If you're on the latest version of MariaDB for your branch, and the nightly updates are working well, then things are working as they should.

    0
  • marjwyatt

    cPRex - Okay.  I will stay with the old "if it ain't broken, don't fix it" algorithm.  Thanks for your speedy response.

    0

Please sign in to leave a comment.