Symptoms
The cPanel service is failing to start.
CONFIG_TEXT:# /scripts/restartsrv_cpsrvd
Waiting for “cpsrvd” to start ……waiting for “cpsrvd” to initialize ………Waiting for cpsrvd,cpaneld,webmaild,whostmgrd to shutdown ... not running.
……failed.
Cpanel::Exception::Services::StartError
Service Status
undefined status from Cpanel::ServiceManager::Services::Cpsrvd
Service Error
(XID djdgnr) The “cpsrvd” service failed to start.
Startup Log
Jun 13 04:10:23 server.exampledomain.tld systemd[1]: Starting cPanel services...
Jun 13 04:10:23 server.exampledomain.tld restartsrv_cpsrvd[24820]: Starting PID 24820: /usr/local/cpanel/libexec/cpsrvd-dormant
Jun 13 04:10:23 server.exampledomain.tld restartsrv_cpsrvd[24820]: License is valid and has already updated recently.
Jun 13 04:10:23 server.exampledomain.tld systemd[1]: Started cPanel services.
Jun 13 04:10:23 server.exampledomain.tld systemd[1]: cpanel.service: main process exited, code=exited, status=25/n/a
Jun 13 04:10:23 server.exampledomain.tld systemd[1]: Unit cpanel.service entered failed state.
Jun 13 04:10:23 server.exampledomain.tld systemd[1]: cpanel.service failed.
cpsrvd has failed. Contact your system administrator if the service does not automagically recover.
Within the cPanel error log, /usr/local/cpanel/logs/error_log there will be entries such as:
CONFIG_TEXT: ==> cpsrvd: loading security policy....Done
==> cpsrvd: Setting up SSL support ... Failed to load SSL libraries or certificate from /var/cpanel/ssl/cpanel/ at cpsrvd.pl line 697.
Cause
The cPanel service has failed due to the file located at /var/cpanel/ssl/cpanel/mycpanel.pem being empty and needs to be moved.
Resolution
Move the empty file and restart the cPanel service.
- Log in to the cPanel and WHM server as the
rootuser via SSH. - Run the following command.
# mv /var/cpanel/ssl/cpanel/mycpanel.pem{,.$( date +%Y%m%d )} -v
# /scripts/restartsrv_cpsrvd
Comments
0 comments
Article is closed for comments.