Symptoms
After the cpanel-unbound package was updated to 11.126.0, various services indicate that the version OPENSSL_3.4.0 was not found. Errors will be shown in the cPanel error log similar to the following:
CONFIG_TEXT: /lib64/libcrypto.so.3: version `OPENSSL_3.4.0' not found (required by /usr/local/cpanel/3rdparty/lib64/libunbound.so.8)
This can also result in the cPanel license becoming expired, which results in a similar message to the following when attempting to login:
CONFIG_TEXT: License File Expired: LTD: 1786994337 NOW: 1786997937
Cause
This is caused by having an outdated OpenSSL version installed older the version 3.4.
Resolution
Ensure the OS release is updated to the latest version::
Perform an update of the almalinux-release package:
# dnf update almalinux-release
For AlmaLinux 8, you should be at AlmaLinux 8.10
For AlmaLinux 9, you should be at AlmaLinux 9.8
For AlmaLinux 10, you should be at AlmaLinux 10.2
Once the release package is updated, perform a dnf update to update all packages:
# dnf update
Perform an update of the CloudLinux-release package:
# dnf update cloudlinux-release
If you encounter any issues updating due to the CloudLinux license, you can run one of the following commands to update your CloudLinux license. CloudLinux licenses purchased from cPanel are IP-based.
IP-based license:
# clnreg_ks --force
Key-based license:
# rhnreg_ks –activationkey= –force
For CloudLinux 8, you should be at CloudLinux 8.10
For CloudLinux 9, you should be at CloudLinux 9.8
For CloudLinux 10, you should be at CloudLinux 10.2
Once the release package is updated, perform a dnf update to update all packages:
# dnf update
Ubuntu OpenSSL version needs to be 3.0.13 which is available on Ubuntu 24. This can be checked using the utility below:
# openssl version
If version is below 3.0.13 then perform an apt update and upgrade.
# apt update && apt upgrade
Comments
0 comments
Article is closed for comments.