Symptoms
Accessing the Sitejet Builder menu in cPanel may result in an error:
CPANEL_ERROR: The request failed. (Error ID: xxxxxx) Ask your hosting provider to research this error in cPanel & WHM's main error log.
Cause
The issue can be caused if the directory of a website previously edited via Sitejet Builder has been removed. The following error will be logged in the cPanel error log:
CONFIG_TEXT: Cpanel::Exception::IO::DirectoryOpenError/(XID ej32ha) The system failed to open the directory “/home/cpuser/public_html/domain.com” because of an error: No such file or directory
at /usr/local/cpanel/Cpanel/Admin/Modules/Cpanel/sitejet.pm line 165.
Cpanel::Admin::Modules::Cpanel::sitejet::_is_empty_directory("/home/cpuser/public_html/domain.com", ARRAY(0x47cef10)) called at /usr/local/cpanel/Cpanel/Admin/Modules/Cpanel/sitejet.pm line 137
...
We've opened an internal case for our development team to investigate this further. For reference, the case number is CPANEL-45765. Follow this article to receive an email notification when a solution is published in the product.
Resolution
Manually create the missing directory shown in the error:
# mkdir -p /home/cpuser/public_html/domain.com
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