Symptoms
After upgrading your operating system using ELevate, entries are missing from /etc/localdomains and /etc/remotedomains causing email to not be received.
Cause
These files are not being restored to their original values after ELevate completes. The original /etc/localdomains and /etc/remotedomains files are backed up to /etc/localdomains.rpmsave and /etc/remotedomains.rpmsave respectively.
We've opened an internal case for our development team to investigate this further. For reference, the case number is CPANEL-46462. Follow this article to receive an email notification when a solution is published in the product.
Resolution
- Log in to the server via SSH or WHM's Terminal as the
rootuser Copy the original files back into place by running the following commands:
# cp -vp /etc/localdomains.rpmsave /etc/localdomains
# cp -vp /etc/remotedomains.rpmsave /etc/remotedomains
Alternatively, you can regenerate the files by running the following command:
# /scripts/checkalldomainsmxs –yes
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