Symptoms
When attempting to run yum or dnf, you get an error similar to the following on a CentOS 7 or CloudLinux 7 server:
CONFIG_TEXT: failure: repodata/repomd.xml from MariaDB106: [Errno 256] No more mirrors to try.
https://archive.mariadb.org/mariadb-10.6/yum/centos/7/x86_64/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found
You will see the following on an AlmaLinux 8 or CloudLinux 8 server:
CONFIG_TEXT: failure: repodata/repomd.xml from MariaDB106: [Errno 256] No more mirrors to try.
https://archive.mariadb.org/mariadb-10.6/yum/centos/8/x86_64/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found
MultiPHP Manager shows:
CONFIG_TEXT: Error: “/usr/local/cpanel/bin/python-packman” reported error code “1” when it ended: Traceback (most recent call last): File "/usr/local/cpanel/bin/packman_get_list_json", line 15, in <module> packman.init_yum() File "/usr/local/cpanel/bin/packman_lib/yum_impl.py", line 78, in init_yum yb.repos.populateSack() File "/usr/lib/python2.7/site-packages/yum/repos.py", line 347, in populateSack self.doSetup() File "/usr/lib/python2.7/site-packages/yum/repos.py", line 157, in doSetup self.retrieveAllMD() File "/usr/lib/python2.7/site-packages/yum/repos.py", line 88, in retrieveAllMD dl = repo._async and repo._commonLoadRepoXML(repo) File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1482, in _commonLoadRepoXML result = self._getFileRepoXML(local, text) File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1259, in _getFileRepoXML size=102400) # setting max size as 100K File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1042, in _getFile raise e yum.Errors.NoMoreMirrorsRepoError: failure: repodata/repomd.xml from MariaDB106: [Errno 256] No more mirrors to try. https://archive.mariadb.org/mariadb-10.6/yum/centos/7/x86_64/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found w/ /usr/local/cpanel/bin/packman_get_list_json installed Often errors like this can be resolved by running `yum makecache`
When cPanel updates run, errors similar to the following will be logged:
CONFIG_TEXT: [/usr/local/cpanel/scripts/update-packages] Errors during downloading metadata for repository 'MariaDB106':
[/usr/local/cpanel/scripts/update-packages] - Status code: 404 for https://archive.mariadb.org/mariadb-10.6/yum/centos/8/x86_64/repodata/repomd.xml (IP: 138.201.152.105)
[/usr/local/cpanel/scripts/update-packages] Error: Failed to download metadata for repo 'MariaDB106': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were trie
This would trigger an email notification:
CONFIG_TEXT: Subject: An error occured while updating server software.
cPanel & WHM failed to update server software.
The system failed to update the server software to the latest versions.
For more information about this error and guidance on how to resolve the error, go to https://go.cpanel.net/sysupfailed.
“update_packages::UpdateFailed” notifications are currently configured to have an importance of “Low”.
This will also occur when updating MariaDB from a version older then 10.6, to 10.6. Or when elevating a server from CentOS/CloudLinux 7 to AlmaLinux/CloudLinux 8 when using MariaDB 10.6 as the Database server.
Cause
The mariadb-10.6/yum/centos/7/ and mariadb-10.6/yum/centos/8/ folders have been removed from the MariaDB archive. We've filed CPANEL-55968 with our developers to ensure when this Repository file is created it's created with the new correct baseurl.
Resolution
Update the baseurl line of the MariaDB repository to reference "almalinux" instead of "Centos":
# sed -i.bk "/baseurl/s|centos|almalinux|g" /etc/yum.repos.d/MariaDB106.repo
If this needs to be reverted for any reason, the backup file can be restored
# mv /etc/yum.repo.d/Mariadb106.repo.bk /etc/yum.repos.d/MariaDB106.repo
# sed -i.bk "/baseurl/s|centos|almalinux|g" /etc/yum.repos.d/MariaDB1011.repo
If this needs to be reverted for any reason, the backup file can be restored
# mv /etc/yum.repo.d/Mariadb1011.repo.bk /etc/yum.repos.d/MariaDB1011.repo
# sed -i.bk "/baseurl/s|centos|almalinux|g" /etc/yum.repos.d/MariaDB114.repo
If this needs to be reverted for any reason, the backup file can be restored
# mv /etc/yum.repo.d/Mariadb114.repo.bk /etc/yum.repos.d/MariaDB114.repo
# sed -i.bk "/baseurl/s|centos|almalinux|g" /etc/yum.repos.d/MariaDB118.repo
If this needs to be reverted for any reason, the backup file can be restored
# mv /etc/yum.repo.d/Mariadb118.repo.bk /etc/yum.repos.d/MariaDB118.repo
An upstream case has been filed with MariaDB:
Comments
0 comments
Article is closed for comments.