Symptoms
Services are down and cannot be restarted. Attempting to create new files or folders on the root filesystem (/) fail with a message similar to the following.
[root@server ~]cPs# touch /test
touch: cannot touch ‘/test’: Read-only file system
Cause
The root filesystem (/) needs to be read-write for services to start.
Resolution
In most cases, the / is mounted as read-only due to filesystem errors. Repairing the filesystem usually involves booting the server into a rescue environment and running fsck or xfs-repair. You should work with your system administrator to correct the filesystem errors.
How can I determine a problem is due to File System Errors?
In some cases, / can be remounted read-write without rebooting the server. The following article explains how to remount a filesystem as read-write.
Comments
0 comments
Article is closed for comments.