Symptoms
When attempting to use features that requires a proxy connection, such as Dynamic DNS, logging in via the Service Subdomains, accessing Webdisk, etc., logs still indicate that the connection is using the localhost IP:
CONFIG_TEXT: warn [cpaneld] proxy trust miss: X-Forwarded-For ignored; localhost peer [127.0.0.1:57648:127.0.0.1:2082] is not a verified trusted proxy (peer UID untrusted, or peer process lookup failed)
This results in Roundcube showing 502 errors, Dynamic DNS reporting the wrong IP, or interrupted login sessions.
These issues continue even after updating to the latest cPanel versions of:
- 11.136.0.23
- 11.134.0.40
- 11.110.0.130
Cause
Due to a recent security update, the internal cPanel proxy was hardened in an attempt to prevent spoofing of the sending IP address. However, this is currently causing valid connections to fail as well, resulting in various issues.
We have opened a case with our developers with case ID CPANEL-54044 to review all associated issues regarding the proxy connections that has been reported. Once further action is taken on this, it will be listed in our changelog.
Where can I locate the cPanel changelogs?
Resolution
If attempting to use a Service Subdomain, consider using the direct port instead.
How-To access cPanel, WHM, and Webmail
For other services that rely on the proxy, there is unfortunately no available workaround at this time.
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