Skip to main content
cPanel Technical Support has been heavily impacted by hurricane Beryl and our ability to respond to tickets has been hindered as a result. We appreciate your understanding and patience as we address these delays.

cPanel & WHM only supports Rocky Linux on version 106 or greater

Comments

6 comments

  • cPanelWilliam
    Hello! Can you try placing the following in /etc/cpupdate.conf
    instead of CPANEL=106
    , then re-attempting the installation? CPANEL=edge
    Let me know if you're still seeing issues afterward.
    0
  • Inna
    Hello! Can you try placing the following in /etc/cpupdate.conf
    instead of CPANEL=106
    , then re-attempting the installation? CPANEL=edge
    Let me know if you're still seeing issues afterward.

    I have tried that, but by replacing edge with 106, but during installation ea4 it threw error (I did not take screenshot or log), and I am now installing the OS again.
    0
  • Inna
    I tried again and this is the error: [2022-06-29 23:28:42 +0430] [11377] ( INFO): Completed execution of "/usr/local/cpanel/scripts/check_cpanel_pkgs --fix --no-broken --no-digest --download-only" in 8.289 second(s) [2022-06-29 23:28:42 +0430] [11377] (FATAL): The background process "EA4 Install" failed with a fatal error: The subprocess reported error number 127 when it ended. 2022-06-29 23:28:42 44 [7419] ( INFO): cPanel is here to help! Our Technical Support team is just a click away at https://support.cpanel.net/ or you can contact Customer Service via email cs@cpanel.net 2022-06-29 23:28:42 118 [7419] (FATAL): The system failed to run the /usr/local/cpanel/scripts/cpanel_initial_install script.
    0
  • cPanelWilliam
    Hello, thank you for your update. I've also been unsuccessful in installing cPanel on my own RockyLinux images. I encountered similar errors to the ones you reported. After conferring with my team, it appears that we are still working on implementing RockyLinux support into v106, where it will be experimental. So, at this time it appears that there are still issues preventing the installation of cPanel on RockyLinux, but our development team is working to address them.
    0
  • Inna
    Regarding errors I should say that I did not add any entry to /etc/cpupdate.conf, so the default version and default behavior is the above error. What I did is I first installed CloudLinux so that error of RockyLinux is gone, then tried installing cPanel 104. BTW, when I first install CloudLinux (in my case 8.6), it installs cPanel 104 by default. But if I try with RockyLinux, it throws error about cPanel should be 106 or greater. The other server I mentioned that was installed around a week ago, it's cPanel version is 104 and I did install with the above method in my case. I think one reason for this error is that the new server does not have a stable network, but main issue is that I should change RockyLinux to CloudLinux, then install cPanel (supposing server has an stable network).
    0
  • cPRex Jurassic Moderator
    At this point we don't officially support RockyLinux, so I wouldn't necessarily expect things to work well. We will likely be adding that OS to our stable, but it's not quite ready yet.
    0

Please sign in to leave a comment.