Skip to main content

Can't connect Dreamweaver via SFTP

Comments

16 comments

  • SimpleSonic
    Make sure the cPanel account you are using has "Shell Access" enabled in the package, because SFTP requires SSH.
    0
  • psytanium
    Shell access is enabled in the assigned package.
    0
  • ffeingol
    Have you tested a SFTP connection with a tool like FileZilla to insure that you can connect? I also do not believe that you need shell access to SFTP.
    0
  • psytanium
    Have you tested a SFTP connection with a tool like FileZilla to insure that you can connect? I also do not believe that you need shell access to SFTP.

    Yes I tried with Filezilla, I cannot connect using SFTP or FTP over SSL / TLS (Implicit encryption) or FTP over SSL / TLS (Explicit encryption), only FTP works.
    0
  • SimpleSonic
    Yes I tried with Filezilla, I cannot connect using SFTP or FTP over SSL / TLS (Implicit encryption) or FTP over SSL / TLS (Explicit encryption), only FTP works.

    In order to use FTP over TLS the FTP hostname needs to have a valid service certificate installed. Since you should have a valid SSL certificate for the server hostname, you should use it for the FTP hostname in FileZilla and test with FTP over TLS and see if it works. If you still have an issue, you may need to open a ticket with cPanel support so they can take a closer look.
    0
  • psytanium
    In order to use FTP over TLS the FTP hostname needs to have a valid service certificate installed. Since you should have a valid SSL certificate for the server hostname, you should use it for the FTP hostname in FileZilla and test with FTP over TLS and see if it works. If you still have an issue, you may need to open a ticket with cPanel support so they can take a closer look.

    Yes I have a valid SSL cert for the server hostname, how can I use it in Dreamweaver / Filezilla ?
    0
  • SimpleSonic
    In your FileZilla connection settings, simply use the servers hostname for FTP hostname. So if your servers hostname is server1.mydomain.com that is what you would enter for the FTP hostname in your connection settings in FileZilla.
    0
  • psytanium
    In your FileZilla connection settings, simply use the servers hostname for FTP hostname. So if your servers hostname is server1.mydomain.com that is what you would enter for the FTP hostname in your connection settings in FileZilla.

    Tried to use the host name server.mydomain.com, it worked only for FTP type.
    0
  • SimpleSonic
    Tried to use the host name server.mydomain.com, it worked only for FTP type.

    You should open a ticket with cPanel support so they can take a look at what"s going on.
    0
  • quietFinn
    Maybe SSh port is not 22, or if it is then port 22 is not opened in firewall :rolleyes:
    0
  • SimpleSonic
    Maybe SSh port is not 22, or if it is then port 22 is not opened in firewall :rolleyes:

    Possibly, but that doesn"t explain why FTP over TLS isn"t working as well.
    0
  • cPanelWilliam
    Hello, I would recommend checking your SSH configuration ( /etc/ssh/sshd_config
    ) to see whether any setting could be conflicting with your SFTP logins. For example, as @quietFinn mentioned, the SSH port could be custom or password authentication could be disabled, which may prevent your SFTP logins. Also, checking /var/log/secure
    for entries with your IP address can help to determine the reason for the login failures. If that still does not help, I'd suggest opening a ticket with our support team so we can get you pointed in the right direction.
    0
  • psytanium
    Ticket ID #95061604 Thanks :)
    0
  • cPRex Jurassic Moderator
    Thanks for that - I'm following along with that ticket on my end now.
    0
  • psytanium
    Thank for the amazing support i always got here on this forum and support tickets. The problem was solved by adding Subsystem sftp /usr/libexec/openssh/sftp-server
    to the file /etc/ssh/sshd_config, and restarting the service /scripts/restartsrv_sshd
    Instructions
    0
  • cPRex Jurassic Moderator
    I'm glad we were able to help!
    0

Please sign in to leave a comment.