Skip to main content
cPanel Technical Support has been heavily impacted by hurricane Beryl and our ability to respond to tickets has been hindered as a result. We appreciate your understanding and patience as we address these delays.

CPANEL-43451 - Issues with cpanel-dovecot-solr-8.11.2-6.6.2.cpanel.noarch update

Comments

36 comments

  • sparek-3
    I'm guessing [font="courier new">cpanel-dovecot-solr-8.11.2-6.6.2.cpanel.noarch was built with [font="courier new">java-1.8.0-openjdk-headless-1:1.8.0.382.b05-2.el8.x86_64, but AlmaLinux released an update to java-1.8.0-openjdk-headless on October 20th: [font="courier new">java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8.x86_64. [font="courier new">cpanel-dovecot-solr-8.11.2-6.6.2.cpanel.noarch is expecting [font="courier new">java-1.8.0-openjdk-headless-1:1.8.0.382.b05-2.el8.x86_64, but is instead finding [font="courier new">java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8.x86_64. Would guess that [font="courier new">cpanel-dovecot-solr-8.11.2-6.6.2.cpanel.noarch needs to be rebuilt with [font="courier new">java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8.x86_64
    0
  • headsup
    The cPanel team should do something this fast as it is causing real issues. Until a fix is pushed, uninstall Dovecot Solr, clear cache, and then run dnf|yum upgrade.
    0
  • natenate19
    No need to remove cpanel-dovecot-solr, it's running fine on java-1.8.0-openjdk-headless-1.8.0.392.b08-4.el8.x86_64. Just add cpanel-dovecot-solr* to the exclude line in /etc/yum.conf and move on. Just remember you've excluded the package, so you can remove the exclude when cPanel fixes the package.
    0
  • AlexParra
    "Hello! I have the same error in CloudLinux v8.8.0: Error: Problem 1: package cpanel-dovecot-solr-server-8.11.2-6.6.2.cpanel.noarch requires java-headless = 1:1.8.0, but none of the providers can be installed - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.372.b07-1.el8_7.x86_64 and java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8.x86_64 - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.372.b07-4.el8.x86_64 and java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8.x86_64 - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.382.b05-2.el8.x86_64 and java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8.x86_64 - cannot install the best update candidate for package java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8.x86_64 - cannot install the best update candidate for package cpanel-dovecot-solr-server-8.11.2-6.6.1.cpanel.noarch Problem 2: package cpanel-dovecot-solr-server-8.11.2-6.6.2.cpanel.noarch requires java-headless = 1:1.8.0, but none of the providers can be installed - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8.x86_64 and java-1.8.0-openjdk-headless-1:1.8.0.372.b07-1.el8_7.x86_64 - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8.x86_64 and java-1.8.0-openjdk-headless-1:1.8.0.372.b07-4.el8.x86_64 - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8.x86_64 and java-1.8.0-openjdk-headless-1:1.8.0.382.b05-2.el8.x86_64 - problem with installed package java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8.x86_64 - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.372.b07-1.el8_7.x86_64 and java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8.x86_64 - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.372.b07-4.el8.x86_64 and java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8.x86_64 - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.382.b05-2.el8.x86_64 and java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8.x86_64 - package cpanel-dovecot-solr-8.11.2-6.6.2.cpanel.noarch requires cpanel-dovecot-solr-server = 8.11.2-6.6.2.cpanel, but none of the providers can be installed - cannot install the best update candidate for package cpanel-dovecot-solr-8.11.2-6.6.1.cpanel.noarch (try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages) I try the solution for exclude from /etc/yum.conf but it seems that it don't work... Can anybody help me to exclude, I wait to cPanel fixes the package.
    0
  • cPRex Jurassic Moderator
    Our team is working on this through case CPANEL-43451, although I don't have an official workaround at this time. I'm hoping I'll get more details throughout the day today.
    0
  • JoseDieguez
    we have been seeing this for a few days (if not a little more), hope this gets fixed :)
    0
  • lestat69
    System update process has started. "/usr/bin/dnf" reported error code "1" when it ended: w/ /usr/bin/dnf upgrade -y Last metadata expiration check: 0:00:49 ago on Tue Oct 24 10:36:13 2023. Error: Problem 1: package cpanel-dovecot-solr-server-8.11.2-6.6.2.cpanel.noarch requires java-headless = 1:1.8.0, but none of the providers can be installed - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.372.b07-4.el8.x86_64 and java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8_8.x86_64 - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.382.b05-2.el8.x86_64 and java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8_8.x86_64 - cannot install the best update candidate for package java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8_8.x86_64 - cannot install the best update candidate for package cpanel-dovecot-solr-server-8.11.2-6.6.1.cpanel.noarch Problem 2: package cpanel-dovecot-solr-server-8.11.2-6.6.2.cpanel.noarch requires java-headless = 1:1.8.0, but none of the providers can be installed - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8_8.x86_64 and java-1.8.0-openjdk-headless-1:1.8.0.372.b07-4.el8.x86_64 - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8_8.x86_64 and java-1.8.0-openjdk-headless-1:1.8.0.382.b05-2.el8.x86_64 - package java-1.8.0-openjdk-1:1.8.0.392.b08-4.el8_8.x86_64 requires java-1.8.0-openjdk-headless(x86-64) = 1:1.8.0.392.b08-4.el8_8, but none of the providers can be installed - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.372.b07-4.el8.x86_64 and java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8_8.x86_64 - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.382.b05-2.el8.x86_64 and java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8_8.x86_64 - package cpanel-dovecot-solr-8.11.2-6.6.2.cpanel.noarch requires cpanel-dovecot-solr-server = 8.11.2-6.6.2.cpanel, but none of the providers can be installed - cannot install the best update candidate for package cpanel-dovecot-solr-8.11.2-6.6.1.cpanel.noarch - cannot install the best update candidate for package java-1.8.0-openjdk-1:1.8.0.392.b08-4.el8_8.x86_64 Problem 3: package cpanel-dovecot-solr-server-8.11.2-6.6.2.cpanel.noarch requires java-headless = 1:1.8.0, but none of the providers can be installed - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8_8.x86_64 and java-1.8.0-openjdk-headless-1:1.8.0.372.b07-4.el8.x86_64 - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8_8.x86_64 and java-1.8.0-openjdk-headless-1:1.8.0.382.b05-2.el8.x86_64 - problem with installed package java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8_8.x86_64 - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.372.b07-4.el8.x86_64 and java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8_8.x86_64 - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.382.b05-2.el8.x86_64 and java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8_8.x86_64 - package cpanel-dovecot-solr-8.11.2-6.6.2.cpanel.noarch requires cpanel-dovecot-solr-server = 8.11.2-6.6.2.cpanel, but none of the providers can be installed - package cpanel-dovecot-solr-contrib-8.11.2-6.6.2.cpanel.noarch requires cpanel-dovecot-solr = 8.11.2-6.6.2.cpanel, but none of the providers can be installed - cannot install the best update candidate for package cpanel-dovecot-solr-contrib-8.11.2-6.6.1.cpanel.noarch Problem 4: problem with installed package java-1.8.0-openjdk-1:1.8.0.392.b08-4.el8_8.x86_64 - package java-1.8.0-openjdk-1:1.8.0.392.b08-4.el8_8.x86_64 requires java-1.8.0-openjdk-headless(x86-64) = 1:1.8.0.392.b08-4.el8_8, but none of the providers can be installed - package cpanel-dovecot-solr-server-8.11.2-6.6.2.cpanel.noarch requires java-headless = 1:1.8.0, but none of the providers can be installed - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8_8.x86_64 and java-1.8.0-openjdk-headless-1:1.8.0.372.b07-4.el8.x86_64 - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8_8.x86_64 and java-1.8.0-openjdk-headless-1:1.8.0.382.b05-2.el8.x86_64 - package cpanel-dovecot-solr-8.11.2-6.6.2.cpanel.noarch requires cpanel-dovecot-solr-server = 8.11.2-6.6.2.cpanel, but none of the providers can be installed - package cpanel-dovecot-solr-contrib-extraction-8.11.2-6.6.2.cpanel.noarch requires cpanel-dovecot-solr = 8.11.2-6.6.2.cpanel, but none of the providers can be installed - cannot install the best update candidate for package cpanel-dovecot-solr-contrib-extraction-8.11.2-6.6.1.cpanel.noarch - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.372.b07-4.el8.x86_64 and java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8_8.x86_64 - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.382.b05-2.el8.x86_64 and java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8_8.x86_64 (try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages) Often errors like this can be resolved by running `dnf makecache` System update process has finished. Any update on a solution?
    0
  • cPanelThomas
    Howdy all, I've been able to replicate the issue, and I believe I have a fix for it. The issue seemed to be a overly specific Requires
    line in the specfile for Alma8. After tweaking this to be less specific (as I had to do earlier for Almalinux 9, oddly enough), that seems to have resolved the problem in my testing. We should have the code merged and testing results replicated soon, so hopefully we can get a new release for this out the door later this week or early next week. Thanks for the reports here, it helped me figure out what was needed to replicate (and thus fix) the issue fairly quickly.
    0
  • natenate19
    An interim solution until the package is fixed is to: yum downgrade java-1.8.0-openjdk-headless
    Exclude java-1.8.0-openjdk-headless in /etc/yum.conf temporarily. yum update
    Remove the exclude from /etc/yum.conf. yum update
    My previous workaround of temporarily excluding cpanel-dovecot-solr was not sufficient for upcp update-packages to run cleanly, but this method appears to be sufficient and should cause no untoward side-effects.
    0
  • johnm86
    I resolved this by using 'yum update --nobest' - then after that completes, run 'yum update' and all works.
    0
  • Zekeman
    Would this also cause the "WHM update failure in upcp Script" error? I have been getting this the last few days and followed it to this error but not sure if this is specifically causing the script error #1 error.
    0
  • cPRex Jurassic Moderator
    @Zekeman - it's possible, as the updates also run over night with the cPanel update.
    0
  • johnm86
    it is the same errors, yes
    0
  • leonep
    Would this also cause the "WHM update failure in upcp Script" error? I have been getting this the last few days and followed it to this error but not sure if this is specifically causing the script error #1 error.

    yes it cause also errors in upcp any news? i have solr working. can i wait for a fix ? or i must do something ? thanks
    0
  • cPRex Jurassic Moderator
    New RPMS for the dovecot-solr package are happening right now, so they should get released today or tomorrow.
    0
  • leonep
    New RPMS for the dovecot-solr package are happening right now, so they should get released today or tomorrow.

    thanks @cPRex
    0
  • Zekeman
    New RPMS for the dovecot-solr package are happening right now, so they should get released today or tomorrow.

    Good to hear!
    0
  • Zekeman
    Any update to this?
    0
  • MSNLD
    Indeed, curious about any update :)
    0
  • Milkboy31
    I resolved this by using 'yum update --nobest' - then after that completes, run 'yum update' and all works.

    I did this but still have the same errors... Not sure why the different result. I updated to 114.0.10 but still have the same issue. Looking forward to a fix from cP. Is this the best place to track this issue or is there an issue repository I'm unfamiliar with? (I'm new here.)
    0
  • bestcarsauto
    ?
    0
  • bestcarsauto
    Any fix or update for this problem trying to update server software? checkyum version 22.3 (excludes: bind-chroot) All Needed Packages are already installed. checkyum version 22.3 (excludes: bind-chroot) Last metadata expiration check: 0:00:40 ago on Sat Oct 28 21:59:51 2023. Error: Problem 1: package cpanel-dovecot-solr-server-8.11.2-6.6.2.cpanel.noarch requires java-headless = 1:1.8.0, but none of the providers can be installed - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.372.b07-1.el8_7.x86_64 and java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8.x86_64 - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.372.b07-4.el8.x86_64 and java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8.x86_64 - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.382.b05-2.el8.x86_64 and java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8.x86_64 - cannot install the best update candidate for package java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8.x86_64 - cannot install the best update candidate for package cpanel-dovecot-solr-server-8.11.2-6.6.1.cpanel.noarch Problem 2: package cpanel-dovecot-solr-server-8.11.2-6.6.2.cpanel.noarch requires java-headless = 1:1.8.0, but none of the providers can be installed - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8.x86_64 and java-1.8.0-openjdk-headless-1:1.8.0.372.b07-1.el8_7.x86_64 - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8.x86_64 and java-1.8.0-openjdk-headless-1:1.8.0.372.b07-4.el8.x86_64 - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8.x86_64 and java-1.8.0-openjdk-headless-1:1.8.0.382.b05-2.el8.x86_64 - problem with installed package java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8.x86_64 - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.372.b07-1.el8_7.x86_64 and java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8.x86_64 - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.372.b07-4.el8.x86_64 and java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8.x86_64 - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.382.b05-2.el8.x86_64 and java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8.x86_64 - package cpanel-dovecot-solr-8.11.2-6.6.2.cpanel.noarch requires cpanel-dovecot-solr-server = 8.11.2-6.6.2.cpanel, but none of the providers can be installed - cannot install the best update candidate for package cpanel-dovecot-solr-8.11.2-6.6.1.cpanel.noarch (try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages) (XID 3mtmph) "/usr/bin/yum" reported error code "1" when it ended:
    0
  • JIKOmetrix
    I'm in the same boat today. Getting error: Problem 1: package cpanel-dovecot-solr-server-8.11.2-6.6.2.cpanel.noarch requires java-headless = 1:1.8.0, but none of the providers can be installed Hope for update soon.
    0
  • davetanguay
    I tried some suggestions in this post which didn't work. I got it working by following doing the following: 1) Uninstall Solr from WHM > Manage Plugins 2) yum update 3) Install Solr from WHM > Manage Plugins 4) yum update Here's what got installed/downgraded when I reinstalled Solr: Downgraded: java-1.8.0-openjdk-headless-1:1.8.0.382.b05-2.el8.x86_64 Installed: cpanel-dovecot-solr-8.11.2-6.6.2.cpanel.noarch cpanel-dovecot-solr-contrib-8.11.2-6.6.2.cpanel.noarch cpanel-dovecot-solr-contrib-extraction-8.11.2-6.6.2.cpanel.noarch cpanel-dovecot-solr-docs-8.11.2-6.6.2.cpanel.noarch cpanel-dovecot-solr-server-8.11.2-6.6.2.cpanel.noarch No more errors for me on 2 of the servers I was having this issue on.
    0
  • JIKOmetrix
    I tried some suggestions in this post which didn't work. I got it working by following doing the following: 1) Uninstall Solr from WHM > Manage Plugins 2) yum update 3) Install Solr from WHM > Manage Plugins 4) yum update Here's what got installed/downgraded when I reinstalled Solr: Downgraded: java-1.8.0-openjdk-headless-1:1.8.0.382.b05-2.el8.x86_64 Installed: cpanel-dovecot-solr-8.11.2-6.6.2.cpanel.noarch cpanel-dovecot-solr-contrib-8.11.2-6.6.2.cpanel.noarch cpanel-dovecot-solr-contrib-extraction-8.11.2-6.6.2.cpanel.noarch cpanel-dovecot-solr-docs-8.11.2-6.6.2.cpanel.noarch cpanel-dovecot-solr-server-8.11.2-6.6.2.cpanel.noarch No more errors for me on 2 of the servers I was having this issue on.

    Good to know. I'll try too.
    0
  • sparek-3
    I'm assuming the fix for this will be in [font="courier new">cpanel-dovecot-solr-8.11.2-6.6.3 but that doesn't appear to have been uploaded yet. I'm guessing once 5PM hits on Friday all RPM building and uploading at cPanel ceases, so maybe we'll see something Monday. Although at this point, I'm not getting my hopes up. Seems to have taken a LONG, LONG time between cPanel acknowledging this (post #9 Oct 24, 2023) and today Oct 29, 2023 and no updated package has yet to make it to the repositories.
    0
  • leonep
    hello any news? [2023-10-30 05:41:05 +0100] - Processing command `/usr/local/cpanel/scripts/update-packages` [2023-10-30 05:41:05 +0100] [/usr/local/cpanel/scripts/update-packages] checkyum version 22.3 (excludes: bind-chroot) [2023-10-30 05:41:09 +0100] [/usr/local/cpanel/scripts/update-packages] This system is receiving updates from CloudLinux Network server. [2023-10-30 05:41:09 +0100] [/usr/local/cpanel/scripts/update-packages] Last metadata expiration check: 1:31:58 ago on Mon Oct 30 04:09:09 2023. [2023-10-30 05:41:09 +0100] [/usr/local/cpanel/scripts/update-packages] Error: [2023-10-30 05:41:09 +0100] [/usr/local/cpanel/scripts/update-packages] Problem 1: package cpanel-dovecot-solr-server-8.11.2-6.6.2.cpanel.noarch requi$ [2023-10-30 05:41:09 +0100] [/usr/local/cpanel/scripts/update-packages] - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.372.b07-1.el8_7.x86$ [2023-10-30 05:41:09 +0100] [/usr/local/cpanel/scripts/update-packages] - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.372.b07-4.el8.x86_6$ [2023-10-30 05:41:09 +0100] [/usr/local/cpanel/scripts/update-packages] - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.382.b05-2.el8.x86_6$ [2023-10-30 05:41:09 +0100] [/usr/local/cpanel/scripts/update-packages] - cannot install the best update candidate for package java-1.8.0-openjdk-hea$ [2023-10-30 05:41:09 +0100] [/usr/local/cpanel/scripts/update-packages] - cannot install the best update candidate for package cpanel-dovecot-solr-se$ [2023-10-30 05:41:09 +0100] [/usr/local/cpanel/scripts/update-packages] Problem 2: package cpanel-dovecot-solr-server-8.11.2-6.6.2.cpanel.noarch requi$ [2023-10-30 05:41:09 +0100] [/usr/local/cpanel/scripts/update-packages] - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8.x86_6$ [2023-10-30 05:41:09 +0100] [/usr/local/cpanel/scripts/update-packages] - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8.x86_6$ [2023-10-30 05:41:09 +0100] [/usr/local/cpanel/scripts/update-packages] - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.392.b08-4.el8.x86_6$ [2023-10-30 05:41:09 +0100] [/usr/local/cpanel/scripts/update-packages] - problem with installed package java-1.8.0-openjdk-headless-1:1.8.0.392.b08-$ [2023-10-30 05:41:09 +0100] [/usr/local/cpanel/scripts/update-packages] - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.372.b07-1.el8_7.x86$ [2023-10-30 05:41:09 +0100] [/usr/local/cpanel/scripts/update-packages] - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.372.b07-4.el8.x86_6$ [2023-10-30 05:41:09 +0100] [/usr/local/cpanel/scripts/update-packages] - cannot install both java-1.8.0-openjdk-headless-1:1.8.0.382.b05-2.el8.x86_6$ [2023-10-30 05:41:09 +0100] [/usr/local/cpanel/scripts/update-packages] - package cpanel-dovecot-solr-8.11.2-6.6.2.cpanel.noarch requires cpanel-dove$ [2023-10-30 05:41:09 +0100] [/usr/local/cpanel/scripts/update-packages] - cannot install the best update candidate for package cpanel-dovecot-solr-8.$ [2023-10-30 05:41:09 +0100] [/usr/local/cpanel/scripts/update-packages] (try to add '--allowerasing' to command line to replace conflicting packages or$ [2023-10-30 05:41:09 +0100] [/usr/local/cpanel/scripts/update-packages] (XID y4xqvr) "/usr/bin/yum" reported error code "1" when it ended: [2023-10-30 05:41:09 +0100] E [/usr/local/cpanel/scripts/update-packages] The "/usr/local/cpanel/scripts/update-packages" command (process 2829774) repor$ [2023-10-30 05:41:09 +0100] The Administrator will be notified to review this output when this script completes
    0
  • JIKOmetrix
    I tried some suggestions in this post which didn't work. I got it working by following doing the following: 1) Uninstall Solr from WHM > Manage Plugins 2) yum update 3) Install Solr from WHM > Manage Plugins 4) yum update Here's what got installed/downgraded when I reinstalled Solr: Downgraded: java-1.8.0-openjdk-headless-1:1.8.0.382.b05-2.el8.x86_64 Installed: cpanel-dovecot-solr-8.11.2-6.6.2.cpanel.noarch cpanel-dovecot-solr-contrib-8.11.2-6.6.2.cpanel.noarch cpanel-dovecot-solr-contrib-extraction-8.11.2-6.6.2.cpanel.noarch cpanel-dovecot-solr-docs-8.11.2-6.6.2.cpanel.noarch cpanel-dovecot-solr-server-8.11.2-6.6.2.cpanel.noarch No more errors for me on 2 of the servers I was having this issue on.

    Just did this today on three servers and they all work as expected now.
    0
  • Milkboy31
    Confirmed this worked for me as well... Uninstalling Solr and running yum update dropped java to 1.8.0.382 (from 392) and then I installed Solr and and ran yum update again and it bumped back up to 392. So now everything is up to date and working. I'd guess this issue will return when another update is due for Solr though... but at least we have a workaround for now.
    0

Please sign in to leave a comment.