Skip to main content
cPanel Technical Support has been heavily impacted by hurricane Beryl and our ability to respond to tickets has been hindered as a result. We appreciate your understanding and patience as we address these delays.

Awstats stopped working

Comments

30 comments

  • cPanelMichael
    Hello :) Check to see if the account is at it's disk space limit. If not, try updating it's statistics manually and see if you notice any error messages. EX: /scripts/runweblogs $username
    Thank you.
    0
  • whipworks
    Thanks! No error showed up and space seems to be fine. [2014-09-16 13:29:15 -0400] Process bandwidth for [2014-09-16 13:29:17 -0400] Disk Usage for on /dev/mapper/VolGroup00-LogVol00 (22336/256000) [2014-09-16 13:29:17 -0400] Archive Status for : 1 [2014-09-16 13:29:17 -0400] Skipping , no activity since 0 [Wed Dec 31 19:00:00 1969] (domains:1 domains)
    0
  • cPanelMichael
    Are you sure this is only happening for one account on your system? The output you provided indicates no new activity. Are statistics logged to the Apache domlog file for that domain name (/usr/local/apache/domlogs/domain.com)? Thank you.
    0
  • whipworks
    That's the problem. It stopped registering activity. Last one was 3 days ago. Then the succeeding days was just plain zero on all stats. Even when the site have been visited.
    0
  • cPanelMichael
    Have you tried visiting the website to see if new entries appear? Are you sure the domain name is pointed to the server? Is this the only domain name experiencing the problem? Thank you.
    0
  • whipworks
    Yes. All DNS zone records point to the correct server. I went to the site a couple of times today, but it still didn't register on the stats.
    0
  • cPanelMichael
    Is this the only domain name experiencing the problem? Feel free to open a support ticket using the link in my signature so we can take a closer look. You can post the ticket number here so we can update this thread with the outcome. Thank you.
    0
  • whipworks
    Hmm... after looking at 4 other domains, it looks like it's a server wide issue.
    0
  • cPanelMichael
    Are you using any third-party applications such as Nginx that alter the default Apache configuration? Thank you.
    0
  • whipworks
    I don't think so. And I don't see anything on the Global Configuration. Or maybe I don't know where to check it.
    0
  • cPanelMichael
    Feel free to open a support ticket using the link in my signature so we can take a closer look. You can post the ticket number here so we can update this thread with the outcome. Thank you.
    0
  • whipworks
    [quote="cPanelMichael, post: 1731812">Feel free to open a support ticket using the link in my signature so we can take a closer look. You can post the ticket number here so we can update this thread with the outcome. Thank you.
    Request id is: 5473335
    0
  • cPanelPeter cPanel Staff
    Hello, We're awaiting access to your server.
    0
  • whipworks
    [quote="cPanelPeter, post: 1732251">Hello, We're awaiting access to your server.
    Hi, Sorry for the delay. I was out on leave. I couldn't grant access anymore. Do I need to re-open the ticket?
    0
  • cPanelMichael
    You can update the existing ticket with the authentication details. Opening a new ticket is not required. Thank you.
    0
  • whipworks
    [quote="cPanelMichael, post: 1733601">You can update the existing ticket with the authentication details. Opening a new ticket is not required. Thank you.
    Hi Michael, Where can I find this? I tried to re-open the ticket on the customer portal. Don't know if that went through.
    0
  • cPanelMichael
    Documentation on this is available here: How to Authenticate Your Server Ensure you reply to the ticket after updating the authentication details so we know to proceed. Thank you.
    0
  • whipworks
    As per Peters email, I've done the said procedure. Now awaiting for a response.
    0
  • cPanelMichael
    [quote="whipworks, post: 1733732">As per Peters email, I've done the said procedure. Now awaiting for a response.
    You must re-open the ticket because you previously closed it. Thank you.
    0
  • whipworks
    [quote="cPanelMichael, post: 1733741">You must re-open the ticket because you previously closed it. Thank you.
    I have. This is the 3rd time I'm actually doing the re-opening process.
    0
  • cPanelPeter cPanel Staff
    Hello, To confirm this was caused by a syntax error in the Apache configuration (httpd.conf) file. A syntax error will prevent Apache from restarting gracefully and will also prevent the domlogs from updating. They remain at 0 bytes so when stats runs, no data is available to update.
    0
  • whipworks
    Thanks Peter! Much appreciated :)
    0
  • davidhan
    That is the problem that I'm interested. It stopped registering activity. Last one was 3 days ago. Then the succeeding days was just plain zero on all stats. Even when the site have been visited.
    0
  • whipworks
    [quote="davidhan, post: 1734631">That is the problem that I'm interested. It stopped registering activity. Last one was 3 days ago. Then the succeeding days was just plain zero on all stats. Even when the site have been visited.
    cPanelPeter was able to resolve the issue. Unfortunately, I just found out that another server has the same issue. I'm thinking probably all of our CPanel server has this. I tried updating an SSL cert on one of our accounts and surely enough that mycpanel.pem does not exist. This is beginning to be a pain.
    0
  • cPanelMichael
    [quote="davidhan, post: 1734631">That is the problem that I'm interested. It stopped registering activity. Last one was 3 days ago. Then the succeeding days was just plain zero on all stats. Even when the site have been visited.
    Have you reviewed the previous responses to this thread to see if any of them are helpful? Could you provide some more details about the troubleshooting steps you have taken thus far? Thank you.
    0
  • Mario Franco
    [quote="cPanelPeter, post: 1733791">Hello, To confirm this was caused by a syntax error in the Apache configuration (httpd.conf) file. A syntax error will prevent Apache from restarting gracefully and will also prevent the domlogs from updating. They remain at 0 bytes so when stats runs, no data is available to update.
    Hi, I also have the same problem with all accounts in a server I'm currently managing. Awstats and other stats programs suddenly stopped updating. I've tried all the troubleshooting methods explained here and in other forums. When updating from Shell (through runweblogs) I get the following message at the end of the output: [2014-10-24 00:45:15 -0500] Skipping $username, no activity since 0 [Wed Dec 31 18:00:00 1969] (domains:1 domains) Also I've restarted Apache to see if there was a misconfiguration in the httpd.conf file and it restarted without problem and the stats issue remains. Any ideas what may be causing this? Thanks! Mario
    0
  • cPanelMichael
    Are you using any third-party applications such as Nginx that alter the default Apache configuration? Thank you.
    0
  • Mario Franco
    No, no third-party application is been used. Thanks
    0
  • cPanelMichael
    Feel free to open a support ticket using the link in my signature and post the ticket number here. Thank you.
    0
  • cre8gr
    I'm having the same issues for 3 days now. My configuration has nginx as a proxy, but up until now bandwidth logs where calculated successfully. This happens to all of the domains hosted. Some of them show bandwidth and user access only from AWstats (cPanel's Monthly Bandwidth Transfer is on halt), but I know it's wrong, as user access is much higher than what they say. The only thing I remember changing is at /etc/named.conf where I added in both options and external: [quote]recursion no; additional-from-auth no; additional-from-cache no;
    To stop DNS query cache attacks. I runned /scripts/runweblogs $username but that didn't do the trick either. Also most of the domains have no entry in their /usr/local/apache/domlogs/domain.com file
    0

Please sign in to leave a comment.