cpauthd: Invalid password in passdb: crypt() failed: Invalid argument
We have an issue where all email accounts on our server are failing authentication following a server reboot. The logs show:
Sep 25 20:52:10 server dovecot[2579]: auth-worker(emailaddress,116.91.221.230)<21165><KFsVgkxcKw50W93m>: request [9]: Error: cpauthd: Invalid password in passdb: crypt() failed: Invalid argument
Sep 25 20:52:10 server dovecot[2579]: imap-login: Login aborted: Logged out (auth service reported temporary failure, 1 attempts in 2 secs) (temp_fail): user=<emailaddress>, method=PLAIN, rip=xxxx, lip=xxxxxx, TLS, session=<dYD1gUxct+GvJJVY>
Cloudlinux 8 Cpanel 138.0 (build 10)
-
Problem solved. ran this and everything started working again. Ridiculous. Just ridiculous.
/usr/local/cpanel/cpkeyclt
0 -
Hey hey! If the license detection isn't working properly it will suspend the email authentication process. More details on what all happens here:
It's odd that a simple reboot would trigger this though. Was there anything else in the main cPanel log that indicated a license issue?
0 -
Nothing that is glaringly obvious.
The cpanel log shows the shutdown and restart and the license failing to activate.
[2026-09-25 19:59:05 +1000] info [cpsrvd] version 11.138.0.10 online
[2026-09-25 20:20:15 +1000] info [restartsrv_cpanel_php_fpm] The service 'cpanel_php_fpm' appears to be already down. Nothing was stopped.
cpsrvd [1657205] Shutting down due to SIGTERM
[2026-09-26 20:22:48 +1000] info [run_plugin_lifecycle] Nothing to do for cpanel-xovi-plugin.
-- RESTART MARKER (PID 2262 at Sat Sep 26 20:23:00 2026 - 1790367780)--
==> cpsrvd 11.138.0.10 started
==> cpsrvd: loading security policy....Done
==> cpsrvd: Setting up SSL support ... Done
License Check Failed during startup of cpsrvd: License not activated
==> cpsrvd: transferred port bindings: 3,4,5,6,7,8,9,10,11,12
==> CONFIGURATION CHANGE: closing FD 11 (webmail, port 2095)
==> CONFIGURATION CHANGE: closing FD 12 (webmail_ssl, port 2096)
==> cpsrvd: bound to ports
License Check Failed: License not activated
[2026-09-26 20:23:01 +1000] info [cpsrvd] version 11.138.0.10 online
dovecot auth service not ready
dovecot auth service not ready
......
dovecot auth service not ready
dovecot auth service not ready
[2026-09-25 20:23:26 +1000]: “/usr/local/cpanel/scripts/restartsrv_apache_php_fpm --graceful” called by (10021 - /usr/local/cpanel/scripts/restartsrv_httpd --no-verbose)Anyway, given no mechanism exists to alert us when a license fails and the impact when it happen is highly disruptive we'll write a script that reports it by SMS.
Thanks.
0 -
If you have the option, that might be worth making a ticket about. It almost seems like a race condition of some sort during the restart.
0 -
I am also facing same problem, even not able login cPanel,
0 -
Arslan Azam - do you have root access to the server?
0
Please sign in to leave a comment.
Comments
6 comments