Symptoms
You have found that the IPv6 address used for outgoing IPv6 connections keeps changing to various IPv6 addresses.
Cause
It is possible for the outgoing IPv6 address to change if your server's network configuration has a range of more than one IPv6 address configured in the IPV6ADDR line of the network-scripts configuration file.
CPANEL_WARN: Making changes to your network configuration incorrectly can result in a loss of connectivity. Either the server's System Administrator or the hosting provider should be consulted to verify these changes. The steps below are provided as a general guide.
Resolution
Login to the server using Console Access as the root user.
Note: We recommend against using SSH or the Terminal in WHM when making changes to your network configuration. Please work with your hosting provider if you do not have Console Access.
Get a list of the available network device names on your server:
# find /sys/class/net/ -type l -printf "%f\n"
lo
eth0Note: If there is only one interface name listed other than
lo, make note of that and continue to step 3.Otherwise, check your server's main IP:
# ip a
Note: The server's main interface will have an
inetentry that matches your server's main IP address.Make a backup of the network configuration script for the main interface. In the below example the filename portion
INTERFACENAMEwould be replaced with your interface name:# cp -v /etc/sysconfig/network-scripts/ifcfg-INTERFACENAME /root/
Note: Most commonly, the interface name is enoX or ethX for example "/etc/sysconfig/network-scripts/ifcfg-eth0". The value for X can represent the number of the interface if multple interface configurations are in place.
- Open the network configuration script with your preferred text editor and look for the
IPV6ADDRconfiguration Ensure the entry matches your main shared IPv6 address with
/128at the end. An example would look similar to this:# IPV6ADDR="2001:0db8:ffff:ffff:ffff:ffff:ffff:ffff/128
Note: The /128 suffix ensures that only a single IP address is bound to this network interface. With a different suffix, or none at all, this will result in multiple IPs being used by this interface.
Once you have updated the configuration, restart the network configuration with the following command:
# /usr/bin/systemctl restart network
CPANEL_WARN: If the network service fails to start, you may restore the backup configuration that you created in step 3 and then restart the service once more to restore network connectivity.
- Login to WHM as the root user and navigate to: WHM Home / Server Configuration / Basic WebHost Manager® Setup
- Ensure that the same IPv6 address has been added to that interface
Navigate to: WHM Home / IP Functions / IPv6 Ranges
Note: Ensure that you have configured your gateway and IPv6 Ranges properly in this interface. If you are unsure of what to change here, please consult with your hosting provider or network administrator.
Comments
0 comments
Article is closed for comments.