Symptoms
With Imunify360 installed, outgoing SMTP restrictions are unable to complete. You may receive errors reaching other hosts, or SSL mismatches referencing your server's own hostname:
CONFIG_TEXT: SwiftTransportException: Connection could not be established with host remotehost.name.tld :streamsocket_client(): Unable to connect to ssl://remotehost.name.tld:465 (Connection refused)
CONFIG_TEXT: SMTP Error: Could not connect to SMTP host.
CONFIG_TEXT: Connection failed. stream_socket_enable_crypto(): Peer certificate CN=server.hostname.tld did not match expected CN=smtp.gmail.com
Cause
Imunify360 can enable SMTP traffic restrictions that prevent most users from making outbound connections. This is similar, but separately managed from the SMTP Restrictions in WHM, or the SMTP_BLOCK settings in CSF.
Resolution
You can manage the SMTP Traffic settings in Imunify360's interface.
- Access your server using WHM as the root user.
- Navigate to "Plugins / Imunify360".
- Within Imunify360, select "Settings" and locate "SMTP Traffic Management".
- You can disable the SMTP traffic management or add the user to the whitelist who is trying to make outbound SMTP connections.
- Save your settings to commit the changes.
Additional Information
CloudLinux: How to use SMTP Management?
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