Symptoms
When updating the PHP version of a domain in Home / Software / MultiPHP Manager or running /usr/local/cpanel/bin/rebuild_phpconf, you will receive an error similar to the following.
CPANEL_INFO: DEFAULT PHP: ea-php82
Cpanel::Exception::MissingParameter/(XID dd6myh) Provide the “type” parameter for the “Cpanel::WebServer::Supported::apache::make_handler” function.
at /usr/local/cpanel/Cpanel/WebServer/Supported/apache.pm line 223.
Cpanel::WebServer::Supported::apache::make_handler(Cpanel::WebServer::Supported::apache=HASH(0x905c2c8), "lang", Cpanel::ProgLang::Supported::php=HASH(0x8fbe658), "package", "alt-php53", "type", undef) called at /usr/local/cpanel/bin/rebuild_phpconf line 194
bin::rebuild_phpconf::ea4::do_current(HASH(0x8f17bb8), Cpanel::ProgLang::Supported::php=HASH(0x8fbe658), Cpanel::WebServer::Supported::apache=HASH(0x905c2c8)) called at /usr/local/cpanel/bin/rebuild_phpconf line 226
bin::rebuild_phpconf::ea4::run(ARRAY(0x88fcd98)) called at /usr/local/cpanel/bin/rebuild_phpconf line 246
Description
This error occurs when the /etc/cpanel/ea4/php.conf file is empty.
Workaround
- Access the server's command line as the
rootuser via SSH or via the WHM Home / Server Configuration / Terminal. - Reinstall at least one ea-php## package
# dnf reinstall ea-php##
Warning: Please note that "##" must be replaced with the PHP version without the decimal point (i.e., 81 for PHP 8.1).
Comments
0 comments
Article is closed for comments.