Symptoms
You receive an email notification with a subject similar to:
CONFIG_TEXT: The system detected that one or more templates were updated as a result of a change in the EasyApache 4 environment.
Cause
This occurs when EasyApache 4 updates change the default template, which means that custom templates may need to be updated to follow suit.
Resolution
- Access the server's command line as the 'root' user via SSH or Terminal in WHM.
-
Review the templates folder for any custom templates.
# ls -l /var/cpanel/templates/apache2_4/*.local
-
Backup any custom template files found.
# cp -a /var/cpanel/templates/apache2_4/$file.local{,.$(date +%s)}
Note: "$file" must be replaced with the name of the .local file to backup.
-
Use the diff command to look for differences between the default and custom templates.
# diff -u /var/cpanel/templates/apache2_4/$file.default /var/cpanel/templates/apache2_4/$file.local
Note: "$file" must be replaced with the name of the template file.
- Note what changes need to be made.
- Open the .local file in your preferred text editor.
- Make any needed changes to the file.
- Save the changes and exit the text editor.
-
Rebuild the Apache configuration.
# /usr/local/cpanel/scripts/rebuildhttpdconf
-
Restart the Apache.
# /scripts/restartsrv_httpd
Comments
0 comments
Article is closed for comments.